Новости:

Подпишитесь на рассылку новых сообщений форума через службу рассылок: Subscribe.ru

Главное меню

Сортировка рейтинга в excel

Автор draw, 27.12.2016, 15:37

« назад - далее »

draw

Здравствуйте!
Обращаюсь к Вам за помощью.
Есть таблица, диаграмма. Не могу настроить сортировку этого рейтинга.
На пальцах объясню в чем проблема:  у тани было 3, саши - 2, кати - 1 (1,2 и 3 места). Но когда у Кати становится 5, к примеру,  она остается на том же третьем месте. А нужно, что бы перескакивала на первое.

Надеюсь, на помощь. Вкладываю файл с этой проблемой)

vikttur

#1
Непонятно. Нужно присваивать место? Используйте функцию РАНГ
Перемещать значения в таблице? В доп. столбцах строить новую таблицу на основе ранга в первой
Ранг:
=РАНГ(C2;$C$2:$C$34)+СЧЁТЕСЛИ($C$2:C2;C2)-1
В новую таблицу:
=ВПР(СТРОКА(A1);$A$2:$C$34;2;)

draw

Да, нужно присваивать место.
А как это на примере?..если честно никогда не сталкивался с такой функцией.

vikttur

Добавил пример в свое предыдущее сообщение.

zs5

 Varians:
=ИНДЕКС($B$2:$B$34;ПОИСКПОЗ(НАИБОЛЬШИЙ($C$2:C34;СТРОКА(A1));$C$2:$C$34;0)+СЧЁТЕСЛИ($C$2:C2;C2)-1;1)