Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Главное меню

Копирование значений ячеек через заданный интервал

Автор xrust666, 11.01.2017, 08:48

« назад - далее »

xrust666

Добрый день,
необходимо перенести определенные ячейки из одной книги в другую с определенным интервалов ( через 4 ячейки):
A22=A5 F22=A3 N22=D6 W22=D5
A23=A9 F23=A7 N23=D10 W23=D9
... ... ... ...

Как создать формулу чтобы автоматом растянуть на все остальные ячейки.

Файлы во вложении ( из файла 1 в файл 2)

IKor

Растянуть единую формулу вряд ли получится - слишком сложная формула.
ИМХО проще использовать "полуавтоматический" подход:
1. создать копию значимой части таблицы из накладной
2. руками удалить лишние столбцы (необязательно)
3. руками добавить по три пустые строки между каждой из значимых строк вспомогательной таблицы: важно, чтобы расстояние между значимыми строками вспомогательной таблицы соответствовало расстоянию между строками выходной таблицы
4. руками прописать формулы для первой группы выходного документа (в виде "равно соответствующему значению вспомогательной таблицы". Важно: нужно использовать относительные ссылки - без "$")
5. убедиться в том, что в области A3:D6 нового документа присутствуют только формулы, ссылающиеся на вспомогательный документ - удалить лишние значения или смириться с тем, что их затем придется править
6. скопировать этот диапазон и вставить его во все строки ниже - ссылки должны корректно измениться

P.S. Теоретически свои действия можно записать макрорекодером, отредактировать полученный макрос и пользоваться им в дальнейшем.

xrust666

Помогли на другом форуме, вот эта формула прекрасно справляется с задачей =ИНДЕКС([1.xlsx]TDSheet!$A:$A;5+4*(СТРОКА(A1)-1))

IKor

Меня несколько смущает тот факт, что в один столбец второго документа следует копировать данные сразу из двух столбцов первого: поэтому, как мне кажется: единой формулой указанного вида (например, для ячеек А3 и А5 второго файла) обойтись не получится, но если Вам это не мешает, то я очень рад... :)

В любом случае благодарю Вас за то, что оставили решение этой задачи и на нашем форуме.