Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Суммеслимн и переменные диапазоны суммирования

Автор dsNiper, 18.01.2017, 11:02

« назад - далее »

dsNiper

Тему описал как смог.
Смысл такой.
Есть необходимость квартально делать отчет по значениям поступлений.

=СУММЕСЛИМН(Оплаты16!I2:I378;Оплаты16!G2:G378;А6;Оплаты16!E2:E378;"А7")
Вот такой формулой считается нужная сумма. Но каждый квартал столбец в котором суммируется меняется, т.е. в следующем формула будет, например
=СУММЕСЛИМН(Оплаты16!Z2:Z378;Оплаты16!G2:G378;А6;Оплаты16!E2:E378;"А7")

Соответственно вопрос. Есть ли какие-то способы не менять диапазон в ручную в каждой формуле, а сделать это как-нибудь автоматизировано?

Serge 007

Есть.
При наличии файла-примера всё можно сделать
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

dsNiper


boa

через поиск позиции
=SUMIFS(INDIRECT("R7C"&MATCH(R13C;R6C5:R6C7;)+4&":R10C"&MATCH(R13C;R6C5:R6C7;)+4;);R7C2:R10C2;1) - для 14-й строки
=SUMIFS(INDIRECT("R7C"&MATCH(E$13;$E$6:$G$6;)+4&":R10C"&MATCH(E$13;$E$6:$G$6;)+4;);$B$7:$B$10;1)
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

dsNiper

#4
Интересно... не знаю половину этих функций. Буду вникать. Спасибо за помощь)

zs5

#5
для поиска по месяцам
=СУММЕСЛИМН(ДВССЫЛ(АДРЕС(ПОИСКПОЗ:ДВССЫЛ...

dsNiper

#6
Подскажите пожалуйста чайнику, как понимать в формуле =СУММЕСЛИМН(ДВССЫЛ("R7C"&ПОИСКПОЗ(R13C;R6C5:R6C7;)+4&":R10C"&ПОИСКПОЗ(R13C;R6C5:R6C7;)+4;);R7C2:R10C2;1)


boa

#7
В ячейке R13C находится имя месяца за который надо получить отчет.
В примере я сделал данную ячейку с выпадающим списком, который берется из диапазона R6C5:R6C7.
В диапазоне R6C5:R6C7 мы ищем совпадение и подставляем номер позиции найденного месяца в формулу. "+4" - потому, что диапазон начинается с 5-й колонки. В результате получаем Номер колонки для искомого месяца.
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

dsNiper

#8
кнопка цитирования не для ответа [МОДЕРАТОР]

Как работает я понял. Я не понял, почему это работает)). R13C - это 13 строка столбец без номера. так как эксель понимает, что имеется ввиду R13C5?

boa

если номер столбца не указан, то формула ссылается на текущий столбец

Зачем нужен стиль ссылок R1C1
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра