Запрет повторяющихся значений

Автор Александр Смирнов, 18.01.2017, 18:15

« назад - далее »

Александр Смирнов

Добрый день, подскажите пож-та, имеется список фамилий, н-р, в столбце А, как сделать запрет на повторяющиеся фамилии, которые находятся на другом листе, или даже лучше, другом файле))

vikttur

Фамилии уже есть, какой запрет может быть? На повторный ввод? копирование?

Александр Смирнов

#2
Запрет на повторный ввод

zs5

#3
Уф;формула =ПОИСКПОЗ(A2;$A$1;0);цвет текста
P.S. как вариант =ПОИСКПОЗ(A2;$A$1;-1)

Александр Смирнов

Пока не получается. Имеется Лист 1, на котором будут вноситься ФИО в течении дня, на следующий день всё подчищается и вносятся другие ФИО.
Имеется Лист2, где будут ФИО, которые вносились на первом листе за каждый день
Как сделать, чтобы при повторном вводе ФИО на лист1, вылетало предупреждение (т.к. ФИО уже такое было, см. лист2)

TimSha

Цитата: Александр Смирнов от 19.01.2017, 10:09...
Как сделать, чтобы...
Макросом, потому как другие варианты бессильны при копи\пасте значений, однако... ;)
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)

zs5

=ЕСЛИ(СУММПРОИЗВ((A9=$A$3:$A$6)*1)>0;"предупреждение";"")