Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Указание динамического диапазона при суммировании

Автор Shadowmaker, 02.02.2017, 09:41

« назад - далее »

Shadowmaker

Вопрос такой:
Есть формула использующая массив - ну пусть будет СУММ(A10:A20)
Смысл в том, что этот массив динамический и может быть любым - как A1:A20, так и A19:A20 и т.п.
Какой именно это будет диапазон определяется в других ячейках - ну пусть это будут B1 и B2.
В B1 находим начало диапазона а в B2 конец.

Как мне в изначальной формуле СУММ(A10:A20) подставить значения из B1 и B2 чтобы получилось что-то типа СУММ(A{B1}:A{B2})

vikttur

#1
=СУММ(ИНДЕКС(A:A;B1):ИНДЕКС(A:A;B2))
В В1, В2 номера строк.
Если указаны ссылки (типа А20):
=СУММ(ДВССЫЛ(B1&":"&B2))
Не рекомендую: формула пересчитываеся при любом изменении на листе.

Shadowmaker