Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

копирование с заданым интервалом столбцов

Автор Ена, 11.02.2017, 13:11

« назад - далее »

Ена

Прошу прощения за вероятнее всего простейший вопрос, но очень нужна помощь
Нужно скопировать ячейки с листа "Оборот" строка с названием "Итого" (может меняться ее адрес при дальнейшем добавлении товаров в течении месяца) на лист "Отчет" за каждый день соответственно.

Можно ли изменить название столбцов "сальдо на кон." на "сальдо на ДАТА СЛЕДУЮЩЕГО ДНЯ"
 

boa

Prihod  =INDIRECT("РѕР±РѕСЂРѕС,!R15C"&MATCH(R1C;РѕР±РѕСЂРѕС,!R2;0)+2;FALSE)
Prodaga =INDIRECT("РѕР±РѕСЂРѕС,!R15C"&MATCH(R1C;РѕР±РѕСЂРѕС,!R2;0)+4;FALSE)

РѕР±РѕСЂРѕС, - Imya lista s kotorogo berem dannie
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

Ена

Спасибо огромное за помощь!
Я правильно поняла
Приход=INDIRECT("оборот!R15C"&MATCH(R1C;оборот!R2;0)+2;FALSE)
Продажа=INDIRECT("оборот!R15C"&MATCH(R1C;оборот!R2;0)+4;FALSE)
Что-то не получилось, ошибка в формуле(

boa

Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

boa

Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

Ена

Спасибо огромное за ликбез! Буду пробовать. Я могу как-то Вас отблагодарить? :) Может как-то на рейтинг повлиять, или здесь такого нет?

zs5

#6
)
=ИНДЕКС(Лист1!$D$2:$AL$15;14;--ПОИСКПОЗ(B1;Лист1!$D$2:$AL$2;0)+2)
=ИНДЕКС(Лист1!$D$2:$AL$15;14;--ПОИСКПОЗ(B1;Лист1!$D$2:$AL$2;0)+2*2)
С УВАЖЕНИЕМ, ZS