Перенос заливки из одного файла в другого

Автор Диана Нурушева, 04.03.2017, 21:48

« назад - далее »

Диана Нурушева

есть два файла: "2 файл" и "3 файл". в каждом нужен только один лист.
во "2 файле" по строкам фамилии, по столбам- даты. в этом файле изначально расставлены оранжевые заливки.
в "3 файле" по строкам фамилии и даты под каждой, столб- время в цифровом формате, причем у людей не все даты могут быть рабочими (нерабочих в таблице нет).
нужно:
1. из 2 файла перенести оранжевые заливки в 3 файл по датам и фамилиям
2. после того как я руками расставлю в 3 файле серые заливки (сама), перенести эти серые заливки во 2 файл по фамилиям и датам.
спасибо!

zs5

лучше работать с правилом, чем с форматированием

Диана Нурушева


zs5

Цитата: zs5 от 09.03.2017, 21:15
Цитата: Диана Нурушева от 04.03.2017, 21:48
после того как я руками расставлю в 3 файле серые заливки (сама)
логика есть

IKor

Диана,

Подумайте о возможности использования дополнительного столбца и условного форматирования:
1. в первом файле вместо использования разноцветной заливки указывайте разные значения напротив фамилий в дополнительном столбце (назначайте атрибуты)
2. с помощью функций ВПР(_), ПОИСИКПОЗ(), ИНДЕКС() и др. передавайте значения аттрибутов из первого файла во второй (в такой же дополнительный столбец)
3. с помощью условного форматирования по указанным значениям (атрибутам) раскрашивайте разными заливками строки с фамилиями в обоих файлах

Диана Нурушева

во 2 файле даты в столбах- добавить доп столб для атрибутов невозможно. я пыталась условным форматированием: трудно форматирование с разными заливками друг на друга накладывать. есть ли возможность как-то макросом, может быть.
пожалуйста...

zs5

тогда два дополнительных столбца:
1. копируйте формулу =A3 (для выделенных ячеек)
2. =ЯЧЕЙКА("тип";B3) в другом столбце
3. =ЕСЛИ(Лист1!C3="l";Лист1!A3;"") формула на другом листе