Создание раскрывающегося списка с условием ЕСЛИ

Автор Ксения П., 27.03.2017, 17:07

« назад - далее »

Ксения П.

Есть 2 ячейки. Если в 1й пусто, то и во 2й пусто, если в 1й есть какое-то значение "", то во 2й должен появиться раскрывающийся список с вариантами Да и Нет.
Знаю функции ЕСЛИ, ЕПУСТО. Знаю, как создать список с помощью проверки данных.
А вот как это объединить? Реально обойтись без макросов?

TimSha

Цитата: Ксения П. от 27.03.2017, 17:07...Реально обойтись без макросов?
Да. Ищем, применяем - "Связанные выпадающие списки".
"Ctrl+S" - достойное завершение ваших гениальных мыслей!.. ;)

zs5

1. в A1 поставить значение
2. выпадающий список пустая строка, да, нет $C$1:$C$3
3. данные- создать список В1- с формулой =ЕСЛИ(A1>0;$C$1:$C$3)
4. убрать значение в А1
5. скопировать В1 в другие ячейки
6. список будет работать только при наличии значения в ячейках первого столбца

Ксения П.

Вот пример.
Если все сделала правильно, то все равно не работает.
Желтым выделена поставленная задача.
Если(В2="*";данет;"")
данет=Е2:Е4 (т.е. пустая строка, да, нет)
В самой ячейке В2 тоже заложена формула, тут либо есть текст, либо нет в зависимости от значения в А2.

zs5

1. пункт 3. данные- создать список В1- с формулой =ЕСЛИ(A1>0;$C$1:$C$3)-не выполнен
2. формула работает с нулем, тем более, ячейка заполнена формулой
3. Если(В2=значение1;знначение2;""), в случае ложь, не "", а 0
4. формируйте первичную зависимость ячеек при наличии значений, затем можно удалить значение и копировать