Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Главное меню

поиск в ячейке слова из списка

Автор Дима Гаврилин, 01.04.2017, 17:29

« назад - далее »

Дима Гаврилин

Пример-таблицу приложил

в первом столбце есть список слов/словосочетаний

в третьем столбце есть список слов, по которым должен производиться поиск

Задача такая: если ячейка из первого столбца содержит слово третьего столбца, то во второй столбец должно проставляться какое-либо значение(формулу я там приложил, но по этой формуле производится поиск только 1го слова из третьего столбца, а не всех)

=ЕСЛИ(ЕЧИСЛО(ПОИСК(D$1;A1;1));"содержит";"не содержит")

Заранее благодарю за помощь

Pelena

формула массива вводится сочетанием клавиш Ctrl+Shift+Enter
=ЕСЛИ(СЧЁТ(ПОИСК(D$1:D$2;A1;1));"содержит";"не содержит")

Дима Гаврилин


zs5

без массива:
=ЕСЛИ(ЕОШИБКА(ПОИСКПОЗ(ПСТР(A1;1;НАЙТИ(".";A1)-1);$D$1:$D$5;0)); "не содержит"; "содержит")