Новости:

Подпишитесь на рассылку новых сообщений форума через службу рассылок: Subscribe.ru

Главное меню

Удалить после первого пробела

Автор Денис Сапунов-Домбровский, 17.04.2017, 20:17

« назад - далее »

Денис Сапунов-Домбровский

Помогите плиз не могу разобраться с ормулой

Пример
Герметик прокладок серый
ФИЛЬТР

Нужно удалить все после первого пробела, если 2 слова и более , то формула работает
А вот если слово одно, то выдает #ЗНАЧ!

Помогите пожалуйста с формулой
Спасибо


zs5

=ЕСЛИ((ДЛСТР(A1)-ДЛСТР(ПОДСТАВИТЬ(A1;" ";"")))>0;ЛЕВСИМВ(ПОДСТАВИТЬ(A1;" ";"!";1);НАЙТИ("!";ПОДСТАВИТЬ(A1;" ";"!";1))-1);A1)

vikttur


kuklp1

ctrl+h→найти " *"→заменить на пусто.
Я, как всегда, чертовски адекватен... Email: kuklp60@gmail.com WM Z206653985942, R334086032478, U238399322728, E332314026771

zs5

#4
=СЖПРОБЕЛЫ(ЛЕВБ(ПОДСТАВИТЬ(A1;" ";ПОВТОР(" ";50));50))