Наибольшее значение, условие

Автор Виталий Поликарпов, 23.05.2017, 20:25

« назад - далее »

Виталий Поликарпов

Подскажите, как вывести значение, если числа равны?

Т8=ИНДЕКС(B4:Q59;ПОИСКПОЗ(T10;Q4:Q59;0);1)
U8=ИНДЕКС(B4:Q59;ПОИСКПОЗ(U10;Q4:Q59;0);1)
V8=ИНДЕКС(B4:Q59;ПОИСКПОЗ(V10;Q4:Q59;0);1)
----------------------------------------------------------
T10=НАИБОЛЬШИЙ($Q$4:Q$59;СТРОКА(B1))
U10=НАИБОЛЬШИЙ($Q$4:Q$59;СТРОКА(B2))
V10=НАИБОЛЬШИЙ($Q$4:Q$59;СТРОКА(B3))
---------------------------------------------------------
Как видно на картинке, ячейки Q7 и Q8 равны. Как при одинаковых числах вывести мне значение ячейки B8?

iron priest

почему именно q8? чем она особенная?

Виталий Поликарпов

Цитата: iron priest от 23.05.2017, 20:37
почему именно q8? чем она особенная?
Эта таблица лидеров турнира по теннису.
в ячейках Q7 и Q8 - сейчас одинаковое кол-во очков, 28.
Т.е получается что у обоих игроков сейчас равное кол-во очков.
А мне надо вывести имя второго игрока в таблицу на второе место, а у меня дублируется имя первого игрока, потому что берется первое наибольшее значение.

vikttur

ЦитироватьКак видно на картинке...
Видно, но формулу в картинке писать не получится.

iron priest

#4
Цитата: Виталий Поликарпов от 23.05.2017, 20:43вывести имя второго игрока в таблицу на второе место, а у меня дублируется имя первого игрока, потому что берется первое наибольшее значение.
если будет 3 или 5 таких позиций, то какую строку выводить?

Виталий Поликарпов

#5
Не жмите бездумно на кнопку цитирования [МОДЕРАТОР]

Цитироватьесли будет 3 или 5 таких позиций, то какую строку выводить?
По порядку первые три начиная с верхней.

Вот полная таблица.

zs5

1 место
=НАИБОЛЬШИЙ(Q7:Q10;1)
2 место
=ЕСЛИ(СЧЁТЕСЛИ(Q7:Q10;НАИБОЛЬШИЙ(Q7:Q10;1))>1;НАИБОЛЬШИЙ(СМЕЩ(Q7;ПОИСКПОЗ(НАИБОЛЬШИЙ(Q7:Q10;1);Q7:Q10;0);):Q10;1))
3 место
=ЕСЛИ(СЧЁТЕСЛИ(Q7:Q10;НАИБОЛЬШИЙ(Q7:Q10;1))>2;НАИБОЛЬШИЙ(СМЕЩ(Q7;ПОИСКПОЗ(НАИБОЛЬШИЙ(Q7:Q10;1);Q7:Q10;0)+ПОИСКПОЗ(НАИБОЛЬШИЙ(Q7:Q10;1);СМЕЩ(Q7;ПОИСКПОЗ(НАИБОЛЬШИЙ(Q7:Q10;1);Q7:Q10;0);):Q10;0);):Q10;1))

Виталий Поликарпов

#7
Не нужно цитировать без необходимости и копировать целыми сообщениями [МОДЕРАТОР]

Ваша формула ищет число, а мне нужно вывести текст из колонки B. напротив этого числа.
И кстати в формуле 3место - выдает ЛОЖЬ.

zs5

Цитата: Виталий Поликарпов от 24.05.2017, 10:14
И кстати в формуле 3место - выдает ЛОЖЬ.
Значит только 2 одинаковых значения.
1 место
=ИНДЕКС(B7:B10;ПОИСКПОЗ(НАИБОЛЬШИЙ(Q7:Q10;1);Q7:Q10;0);1)
2 место
=ИНДЕКС(СМЕЩ(Q7;ПОИСКПОЗ(НАИБОЛЬШИЙ(Q7:Q10;1);Q7:Q10;0)-1;0):B10;ПОИСКПОЗ(НАИБОЛЬШИЙ(Q7:Q10;1);Q7:Q10;0);1)
3 место
=ИНДЕКС(СМЕЩ(Q7;ПОИСКПОЗ(НАИБОЛЬШИЙ(Q7:Q10;1);Q7:Q10;0)+ПОИСКПОЗ(НАИБОЛЬШИЙ(Q7:Q10;1);СМЕЩ(Q7;ПОИСКПОЗ(НАИБОЛЬШИЙ(Q7:Q10;1);Q7:Q10;0);):Q10;0)-1;0):B10;ПОИСКПОЗ(НАИБОЛЬШИЙ(Q7:Q10;1);Q7:Q10;0);1)
когда 3 одинаковых значения

vikttur

#9
Виталий Поликарпов, Вы на замечания будете обращать внимание?

Ряд наибольших:
=НАИБОЛЬШИЙ($Q$4:Q$59;СТОЛБЕЦ(A1))
Фамилии (формула массива, вводится тремя клавишами):
=ИНДЕКС($B$4:$B$59;НАИБОЛЬШИЙ(ЕСЛИ($Q$4:$Q$59=28;СТРОКА($Q$4:$Q$59)-3);СЧЁТЕСЛИ($T$10:T10;T10)))
Перед вводом второй формулы нужно разъединить ячейки. ФМ в объединенные не вводится.

Цитироватьв формуле 3место - выдает ЛОЖЬ.
ЦитироватьЗначит только 2 одинаковых значения.
Вы неправильно поняли. Показывать нужно три лучших результата, не обязательно одинаковые

Виталий Поликарпов

Цитата: vikttur от 24.05.2017, 10:59
Виталий Поликарпов, Вы на замечания будете обращать внимание?
I'm sorry.
-----------------
Три лучших результата, я вывожу с помощью:
=НАИБОЛЬШИЙ($Q$4:Q$59;СТРОКА(B1))
=НАИБОЛЬШИЙ($Q$4:Q$59;СТРОКА(B2))
=НАИБОЛЬШИЙ($Q$4:Q$59;СТРОКА(B3))
Ваша формула =ИНДЕКС($B$4:$B$59;НАИБОЛЬШИЙ(ЕСЛИ($Q$4:$Q$59=28;СТРОКА($Q$4:$Q$59)-3);СЧЁТЕСЛИ($T$10:T10;T10)))
Выводит ИСТИНА, и еще момент ЕСЛИ($Q$4:$Q$59=28... - там не всегда будет значение 28. оно меняется...
Может я не так обьясняю??? Если открыть таблицу. то на 2 месте, сейчас должно быть имя "Кирилл Эл-ль"

zs5

Цитировать
Вы неправильно поняли. Показывать нужно три лучших результата, не обязательно одинаковые
Предлагались условия:
=ЕСЛИ(СЧЁТЕСЛИ(Q7:Q10;НАИБОЛЬШИЙ(Q7:Q10;1))>1
=ЕСЛИ(СЧЁТЕСЛИ(Q7:Q10;НАИБОЛЬШИЙ(Q7:Q10;1))>2

Виталий Поликарпов

2 zs5
См. полную таблицу. Твои решения не работают.

vikttur

ЦитироватьВаша формула... Выводит ИСТИНА
Читайте внимательно:
Цитироватьформула массива, вводится тремя клавишами
Ctrl+Shift+Enter

ЦитироватьТри лучших результата, я вывожу с помощью...
А я Вам показал, как сделать протягиваемую формулу. В Вашем же варианте вместо СТРОКА() достаточно написать номер (1, 2 или 3)

zs5