Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

Как просуммировать в диапазоне с проверкой условия (апгрейд для СУММЕСЛИ)

Автор askiy, 14.06.2017, 22:14

« назад - далее »

askiy

Уважаемые специалисты, добрый день!

Будьте добры, подскажите, пожалуйста, как реализовать идею оператора СУММЕСЛИ (SUMIF), но с апгрейдом:

Нужно не просто сложить ячейки диапазона для строк с определенным названием, а нужно еще и проверить, чтобы по соседней ячейке в соседней строке с другим названием исполнялось условие, задаваемое формулой.

Если выразиться через пример, нужно сложить все "доходы" для "месяцев", отстоящих от базового не далее, чем на определенный временной период. "Месяцы" не связаны между собой порядком, это признаки разных организаций, и поэтому они не упорядочены по возрастанию или убыванию. Столбики в таблице тоже добавлять нельзя, можно только формулой.  :)

Файл-табличку в качестве иллюстрации задачки прилагаю. 

Большое спасибо.

vikttur

=СУММЕСЛИМН(D8:D18;D7:D17;">30000";D7:D17;"<"&D5)
Надежнее:
=СУММЕСЛИМН(D8:D18;A7:A17;"МесяцГод";D7:D17;"<"&D5)

askiy

Огромное Вам спасибо, уважаемый vikttur, за помощь!
Функция и формула работает! :)