Новости:

Подпишитесь на рассылку новых сообщений форума через службу рассылок: Subscribe.ru

Главное меню

Подсчет количества дней за месяц

Автор Tavlad, 19.06.2017, 01:09

« назад - далее »

Tavlad

Добрый день!

Мастерами ведется таблица, в которой указывают дату, номер заказа и свою фамилию.
Задача подсчитать какое количество дней отработал каждый мастер за каждый месяц.

Эксперименты не дали никакого результата, помогите, пожалуйста

Pelena

Здравствуйте.
Проще всего сводной. Но можно и формулой
=СУММПРОИЗВ((ТЕКСТ($A$2:$A$16;"ММ.ГГ")=ТЕКСТ(F$9;"ММ.ГГ"))*($C$2:$C$16=$E10))

vikttur

=СЧЁТЕСЛИМН($C:$C;$E10;$A:$A;">="&F$9;$A:$A;"<="&КОНМЕСЯЦА(F$9;0))

zs5

дополнительный столбец
=МЕСЯЦ(A2)
формула
=СЧЁТЕСЛИМН($D$2:$D$16;МЕСЯЦ(F9);$C$2:$C$16;E10)

Tavlad

#4
Добрый день, Pelena! В вашем примере считает количество заказов за месяц по мастеру, но не количество отработанных дней.
В примерах коллег аналогично считает количество заказов.
Везде выдает, что Иванов отработал в мае 6 дней, но это 6 заказов, а дней там 3

zs5

#5
формула
=СЧЁТЕСЛИМН($E$2:$E$16;МЕСЯЦ(G9);$C$2:$C$16;F10;D2:D16;">="&1)

Tavlad

zs5, А1 - это заголовок столбца
Не совсем понял вашу реализацию

zs5

#7
добавить еще столбец=A3-A2
при А1=1
а формула
=СЧЁТЕСЛИМН($E$2:$E$16;МЕСЯЦ(G9);$C$2:$C$16;F10;D2:D16;">="&1)

zs5

Цитата: Tavlad от 20.06.2017, 11:08
zs5, А1 - это заголовок столбца
Не совсем понял вашу реализацию
не А1, а А2=1
второй дополнительный столбец (условие), а в А3 и далее:
=A3-A2

Tavlad

zs5, я не понял вашу идею и запутался где располагаться должны дополнительные столбцы относительно моей таблицы

zs5

Цитата: Tavlad от 20.06.2017, 14:28
zs5,
где располагаться должны дополнительные столбцы относительно таблицы
пример формулы: данные а1:с16; определение месяца в столбце е; проверка на повтор даты d; итоговая формула по усмотрению

Tavlad

zs5, а вы могли бы выложить ваше решение? Не пойму как у меня А2 может ровняться 1, если у меня в столбце А фиксируются даты

zs5

#12
d2=1

Pelena

Как вариант, формулой тоже с доп. столбцом (файл2)
Или в Excel 2016 можно построить сводную с помощью PowerPivot с подсчётом уникальных значений (файл3)

Tavlad

zs5, есть одна проблема, когда в один день работают 2 мастера. В итоге день будет засчитываться тому, кто первый зафиксировал заказ в таблице.
Pelena, большое спасибо! Ваше решение работает и всего через 1 дополнительный столбец!  sm_clap