Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Сопоставление значений в разных ячейках

Автор Тамара Кубарева, 17.11.2017, 18:09

« назад - далее »

Тамара Кубарева

Добрый день! Есть файл - прайс. В нем колонки артикул,название,цена и т.д. Иногда нужно обновить цены в файле по определенным артикулам, не всем, а присутствующим в другом файле. То есть в другом файле приходят артикулы и новые цены. Мы из другого файла берем две колонки - Артикул2, цена Опт и вставляем эти колонки в первый исходный файл. Структура артикулов в файлах различается. Нужно чтобы артикул 1 нашел сопоставление с артикулом 2 и они построчно выровнялись вместе с ценой опт., то есть чтобы цена Опт от артикула 2 встала в строку артикула 1. Остальные значения Цена опт, не найденных (не сопоставленных артикулов) нужно сделать пустыми, эти строки удаляться из исходного файла.
И еще один вопросик за одно, на втором листе файла. Нужно сразу очистить значения ячеек, не содержащих текст, который содержит, например в данном случае не содержит http. И еще было бы неплохо в случае очистки сделать сдвиг содержащих ячеек влево на место очищенных.

Pelena

Здравствуйте.
Можно формулой
=ЕСЛИОШИБКА(ВПР(A2;$G$2:$H$61;2;0);"")
А второй вопрос к данной теме не относится, нужно создать новую

Тамара Кубарева

Pelena спасибо, то что надо похоже.