Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Подстановка значений из списка по условию

Автор Тимур Зайцев, 30.01.2018, 09:55

« назад - далее »

Тимур Зайцев

Нужно, что бы таблица сама подставляла интерпретацию по условию.
Если значение пустое, значит не проводилось еще исследование, что бы подставляло-"исследование не проводилось", если значение от 0- до7-Соответствует нормальному значению, 8-10- Субклиническая тревога, 11 и выше- Клинически выраженная тревога.
Почитал форумы, написано применить формулу ЕПУСТО , не получается.
Сейчас формула такая.

=ЕСЛИ(B20<7;"Соответствует нормальному значению";ЕСЛИ(И(B20>7;B20<10);"Субклиническая тревога";ЕСЛИ(И(B20>10);"Клинически выраженная тревога"))).
Еще подскажите как лучьше сделать, если есть несколько листов exel , и с первого листа берутся значения во второй лист. На 2 листе идет проверка условия и выдается результат. Сравнивать лучьше с 1 листом или со вторым?
Пример таблицы: https://yadi.sk/d/xDgtm2fo3RuPxE

runner

значение в A1

=ЕСЛИ(A1="";"Исследование не проводилось";ПРОСМОТР(A1;{0;8;11};{"Соответствует нормальному значению";"Субклиническая тревога";"Клинически выраженная тревога"}))

Тимур Зайцев

#2
Очень большой респект!!!! Я и не знал, что так можно. Очень удобно. Намного удобнее , чем если.))

Тимур Зайцев

Правда сейчас подставил пустое значение, выдает как результат "0"-"нормальное значение"  (((
Как быть?

runner

#4
[]

runner

В Вашем случае ссылку можно сделать =ЕСЛИ(ЕПУСТО(ПАЛАТЫ!E3);"";ПАЛАТЫ!E3)   вместо =ПАЛАТЫ!E3

Тимур Зайцев

#6
Вроде получилось. спасибо.