Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Подсчет уникальных значений в столбце по условию дат

Автор AlexSAVV, 01.03.2018, 21:05

« назад - далее »

AlexSAVV

Добрый всем день!
Помогите справиться с задачей.
Есть два столбца, один - ID пользователя, другой - даты. И есть строка с датами по неделям (одна дата - начало недели, другая - окончание недели).
Необходимо посчитать количество уникальных ID пользователей в диапазоне дат (за неделю - за первую, вторую и т.д.).
Есть формула которая считает уникальные значения во всем диапазоне

=СУММПРОИЗВ(СЧЁТЕСЛИ(A2:A46622;A2:A46622)^(2*ЕПУСТО(A2:A46622)-1))

Но не могу соединить с формулой ЕСЛИ(И(начало недели <= диапазон дат;конец недели> диапазон дат);сюда верхнюю формулу;0)

Кто подскажет?
Спасибо!

П.С. Кстати, эта формула подсчета уникальных значений не справляется с диапазоном в 46621 значением в столбце. 10000 считает, а 20000 уже не хочет (пишет 0).

Serge 007

Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

AlexSAVV

Serge 007, файл вложил (не знаю почему первый раз не вложился).
Буду признателен за помощь.