Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Ссылка на "живую" ячейку

Автор Bumcy, 09.03.2018, 20:53

« назад - далее »

Bumcy

Доброго времени суток!
Требуется создать ссылку на ячейку, находящуюся на листе-источнике, причем:
1.При добавлении столбцов/строк на листе-источнике (и, соответственно, смещении целевой ячейки) ссылка должна это учитывать
2.Имя листа-источника вычисляется из имени текущего листа (Листы имеют имена вида 01.2018, 02.2018, 03.2018...)
В приложенном примере имя листа вычисляется, а вот имя ячейки - фиксировано. Можно ли решить задачу без использования именованных ячеек?
В примере строится ссылка в синей ячейке на втором листе на синюю ячейку первого листа.

vikttur

=ВПР("Можно закупить";
ДВССЫЛ(ТЕКСТ(ПСТР(ЯЧЕЙКА("имяфайла";A1);ПОИСК("]";ЯЧЕЙКА("имяфайла";A1))+1;2)-1;"00")&".2018!A1:I99");
ПОИСКПОЗ("Счет на";
ДВССЫЛ(ТЕКСТ(ПСТР(ЯЧЕЙКА("имяфайла";A1);ПОИСК("]";ЯЧЕЙКА("имяфайла";A1))+1;2)-1;"00")&".2018!A1:I1"););)

Не лучше ли ячейку не трогать, закрепить ее на одном месте?

Bumcy

Было бы все так просто... Количество строк перед ячейкой зависит от количества приходов денег, что предсказать невозможно, от кол-ва закупок валюты, от кол-ва платежей... Можно, конечно, сделать таблицы заведомо большими (по 200 строк, к примеру), но ими станет неудобно пользоваться. А, кроме того, периодически возникают идеи по добавлению столбцов, что не дает возможности зафиксировать хотя бы один параметр.
Спасибо за идею цепляться к маркерам!

vikttur

Еще замечание. ДВССЫЛ - летучая функция (пересчитывается при любом изменении на листе). В формуле их две. Это уже два пересчета. А если таких формул несколько?

Присматривайтесь к макросам.