Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Главное меню

Выполнение умножения при определенном условии

Автор Петр Абрамов, 28.06.2018, 11:46

« назад - далее »

Петр Абрамов

Всем привет! Ребята, помогите, пожалуйста!!! Есть длинные столбцы с ценами и долями. Нужно перемножить цену и долю в общем объеме, исходя из артикля. Проблема в том, что объемы указаны еще и по многим др. артиклям, которые мне не нужны. И простое перемножение с помощью "растягивания" столбца приведет к ошибкам. Я понимаю, что нужно сделать такое условие: перемножать в том случае, если артикль по цене = артикль по доле, если такого нет вообще во всем столбце, то 0. Но какую формулу использовать не знаю! Формула "ЕСЛИ с множеством условий - тоже не вариант.

_Boroda_

Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

boa

Добрый день,
Наверное так?

=СУММПРОИЗВ(--($D$2:$D$2736=$G2);$E$2:$E$2736)*$I2
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

Петр Абрамов

Цитата: boa от 28.06.2018, 12:13
Добрый день,
Наверное так?

=СУММПРОИЗВ(--($D$2:$D$2736=$G2);$E$2:$E$2736)*$I2

Проверил простым умножением, неверно...

boa

Цитата: Петр Абрамов от 28.06.2018, 14:46
Проверил простым умножением, неверно...
Для читабельности я между таблицами вставлял пустые колонки, поэтому для вашего файла формула выглядит так:
=СУММПРОИЗВ(--($C$2:$C$2736=$E2);$D$2:$D$2736)*$G2

а лучше откройте файл приложенный к предыдущему посту и посмотрите в нем.
отличие(но не ошибка) может быть лишь в одном случае, если коды в каждой отдельно взятой таблице не уникальны, тогда результат будет просто дублироваться. для каждого дубля кода в таблице с долями.
Но дублей в таблицах нет. Ошибки быть не может!
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра