Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Сравнить значения таблиц последовательно и вывести разницу

Автор Ирина18, 28.07.2018, 05:56

« назад - далее »

Ирина18

Здравствуйте.
Есть файл "Счет" и несколько файлов "Заказ", в файлах заказ присутствуют все позиции товаров и кол-во из "Счет", в "Счет" могут отсутствовать некоторые, которые есть в "Заказ". в фалах "Заказ" позиции могут повторяться между собой, в "Счет" их общее количество.
Можно ли сделать сравнение поочередно, например, "Счета" и "Заказ" с наглядным выведением (цветовая заливка, например или жирное выделение и т. п.) отсутствующих позиций, а также разницы в кол-ве. При этом, если в "Счет" есть, например, "Тетрадь №1" 10шт, они есть в "Заказ 1" 4шт, "Заказ2" 5шт и "Заказ3" 6шт, при сверке "Заказ3", учитывал, что там уже -5

Есть ли путь решения?

P.s. Наименование товаров могут полностью совпадать, либо в них может быть где-то отличие, например лишняя точка, пробел и т. п.  - если есть отличия это сильно осложнит работу?
Примеры прикрепляю

boa

Можно сделать в файле СЧЕТ доп.столбец в который при помощи функции ВПР подтянуть данные из файла ЗАКАЗ
например:
=ЕСЛИОШИБКА(ВПР(RC3;'[ЗАКАЗ-ПРИМЕР.xlsx]Лист1'!R2C1:R9C2;2;0);"")
ну а потом, на основании этого столбца, сделать условное форматрирование
Цитировать(цветовая заливка, например или жирное выделение и т. п.)
Но название товара должно полностью сопадать, в противном случае задача сильно усложняется.
Ну или поищите в интернете функцию поиска по неточному совпадению FuzzyVLOOKUP

Этих столбцов может быть несколько(по количесту ЗАКАЗов) и итоговый столбец с суммой.
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

Ирина18

Спасибо за информацию и идею. Про ВПР и не подумала даже...
Цитата: boa от 28.07.2018, 11:26
Можно сделать в файле СЧЕТ доп.столбец в который при помощи функции ВПР подтянуть данные из файла ЗАКАЗ
например:
=ЕСЛИОШИБКА(ВПР(RC3;'[ЗАКАЗ-ПРИМЕР.xlsx]Лист1'!R2C1:R9C2;2;0);"")


Попробовала, правда, код пришлось подредактировать, у меня сработало вот так.
=ЕСЛИОШИБКА(ВПР(C7;'[ЗАКАЗ-ПРИМЕР.xlsx]Лист1'!$A$2:$B$9;2;0);"")
Как и форматирование работает только при полном совпадении имен, но ручной работы в разы меньше. Попробую с несколькими листами и столбцами еще.
Пошла читать подробно про FuzzyVLOOKUP, с первого взгляда интересно, но как ее сюда "привязать"
Спасибо еще раз.

boa

для ячейки AI111
=ЕСЛИОШИБКА(ВПР(FuzzyVLOOKUP($C111;'[ЗАКАЗ-ПРИМЕР.xlsx]Лист1'!$A$2:$A$9;0);'[ЗАКАЗ-ПРИМЕР.xlsx]Лист1'!$A$2:$B$9;2;0);"")

Цитата: Ирина18 от 28.07.2018, 14:54Попробовала, правда, код пришлось подредактировать, у меня сработало вот так.
у меня привычный стиль ссылок R1C1
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра