Нужна формула по суммированию чисел

Автор Сергей Великоростов, 23.08.2018, 11:35

« назад - далее »

Сергей Великоростов

Добрый день помогите пожалуйста с формулой суммирования чисел в Excel

У меня таблица разбита на 31 день
в ячейках прописаны цифры срабатывания технических средств охраны
Пример:
| 1 день| 2 день| 3 день | 4 день | 5 день |.........|  Всего |
|______|______|______|_______|______|_____ |______|
|  10/1  |  10/4  |    5/1   |    8      |   7/1   |..........|  40/7  |   
первое число: сколько всего за день срабатываний, а второе (через слэш) сколько из них ложных срабатываний
Нужна формула для сложения этих чисел: = 1 день+ 2 день + 3 день...... ВСЕГО: 40/7

vikttur

#1
Сумма левых частей:
=СУММ(--ЛЕВБ(A2:G2;ПОИСК("/";A2:G2)-1))
Сумма правіх частей:
=СУММ(--ПСТР(A2:G2;ПОИСК("/";A2:G2)+1;5))
=суммЛ&"/"&суммП
и ввести формулу как формулу массива - тремя клавишами Ctrl+Shift+Enter

_Boroda_

У меня такой немассивный вариант (работает с 8 и с пусто)
=СУММПРОИЗВ(--ЛЕВБ(ПОДСТАВИТЬ(A2:AE2&"/";"/";"        0");9))&"/"&СУММПРОИЗВ(--ПСТР(ПОДСТАВИТЬ(A2:AE2&"/";"/";"        0");8;9))
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Сергей Великоростов

Спасибо) еще есть вопрос) нужно еще, что бы формула работала и по вертикали,просчитывала ИТОГ (Ячейки с B58-AF58) по дням. (таблица в приложении)

Если можно еще заблокировать данные ячейки (выделенные красным цветом) что бы формулу в последствии не смогли удалить.

boa

Здравствуйте, Сергей,
если использовать формулу Александра(_Boroda_), до для вертикальных подсчетов она будет выглядеть так:
=SUMPRODUCT(--LEFTB(SUBSTITUTE(B$3:B$57&"/";"/";"        0");9))&"/"&SUMPRODUCT(--MID(SUBSTITUTE(B$3:B$57&"/";"/";"        0");8;9))
=СУММПРОИЗВ(--ЛЕВБ(ПОДСТАВИТЬ((B$3:B$57&"/";"/";"        0");9))&"/"&СУММПРОИЗВ(--ПСТР(ПОДСТАВИТЬ((B$3:B$57&"/";"/";"        0");8;9))

А как заблокировать ячейки на листе, лучше расскажет Майкрософт.
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

Сергей Великоростов

Цитировать=SUMPRODUCT(--LEFTB(SUBSTITUTE(B$3:B$57&"/";"/";"        0");9))&"/"&SUMPRODUCT(--MID(SUBSTITUTE(B$3:B$57&"/";"/";"        0");8;9))
=СУММПРОИЗВ(--ЛЕВБ(ПОДСТАВИТЬ((B$3:B$57&"/";"/";"        0");9))&"/"&СУММПРОИЗВ(--ПСТР(ПОДСТАВИТЬ((B$3:B$57&"/";"/";"        0");8;9))


пробую вставить данную формулу, выпадает окно "ошибка в формулы"

можно попросить формулу прописать в моей таблице. (таблица во вложении). За ранее спасибо.


boa

Цитата: Сергей Великоростов от 29.08.2018, 19:04
Цитировать=SUMPRODUCT(--LEFTB(SUBSTITUTE(B$3:B$57&"/";"/";"        0");9))&"/"&SUMPRODUCT(--MID(SUBSTITUTE(B$3:B$57&"/";"/";"        0");8;9))
=СУММПРОИЗВ(--ЛЕВБ(ПОДСТАВИТЬ((B$3:B$57&"/";"/";"        0");9))&"/"&СУММПРОИЗВ(--ПСТР(ПОДСТАВИТЬ((B$3:B$57&"/";"/";"        0");8;9))

Это две одинаковые формулы для русского и англицкого интерфейсов
вам, наверное, нужна вторая...

забирайте из вложения
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра