Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

Столбец, значения в который копируются со смещением

Автор Anastasiaa, 16.09.2018, 22:06

« назад - далее »

Anastasiaa

Добрый день!

Очень надеюсь на помощь!

Нужно создать столбец с названиями города, значения в который будут возвращаться из ячейки соседнего столбца, каждую 61-ю строку значение меняется.
В примере растянула абсолютной ссылкой на ячейку, но в реальности речь идет о сотнях таких строк.

Спасибо!

vikttur

Вряд ли ххх - одинаковые данные. А за них можно было бы зацепиться.
В В17:
=ЕСЛИ(ОСТАТ(СТРОКА(A61);61)=0;C4;ЕСЛИ(СЧЁТЕСЛИ($B$16:B16;B16)=48;"";B16))

boa

Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

Anastasiaa


vikttur

Или пример кривой, или формула неправильно работает.
В примере четко видно, что строки с 49 до 61 должны быть пустые...

boa

Виктор, я не закладывал в формулу вывод пустого значения с 49 до 61

P.S. не "с 49 до 61" а с 0 по 12 или я то же что-то не так вижу
добавил в формулу
=IF(MOD((ROW()-4);61)<13;"";INDEX(C3;TRUNC((ROW()-4)/61;0)*61+4))
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра