Понедельное суммирование по разделам

Автор Григорий Матынов, 03.10.2018, 02:24

« назад - далее »

Григорий Матынов

В файле прикрепленном во в кладке "за неделю" есть 3 с уже прописанными формулами но считай в ручную, просьба подсказать как быстро заполнить всю таблицу??? данные берут формулы из вкладки "за день",  а еще если это возможно как быстро заполнять даты в таком же диапазоне как и во вкладке "за неделю".

vikttur

Название темы - ориентир для поиска. Еще по названию посетитель может понять, стоит ли ему в тему заходить.
Помощь только после изменения названия темы на такое, которое будет отражать задачу.

boa

я бы назвал тему: "Получение сводных данных", т.к. сумиф тут вообще ни при чем
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

vikttur

Понаписали непонятно чего и при этом хотите что-то посчитать...
C Excel лучше общаться на его языке:
- заголовки должны соответствовать разделам ("Зак.запчас." - это совсем не "Заказ запчастей");
- вместо диапазона писать дату начала недели (если нужна вторая дата - в отдельный столбец).
=СУММЕСЛИМН('за день '!$C:$C;'за день '!$B:$B;B$1;'за день '!$A:$A;"<="&$A2+6;'за день '!$A:$A;">="&$A2)

boa

У меня формула чуть посложнее, но тоже имеет право на жизнь  ;)
=IFERROR(
SUMPRODUCT(Таблица1[Сумма за день];
--(Таблица1[[Дата ]]>=DATEVALUE(MID(RC1;1;SEARCH("-";RC1)-1)));
--(Таблица1[[Дата ]]<=DATEVALUE(MID(RC1;SEARCH("-";RC1)+1;10)));
--(R1C=Таблица1[Раздел])
);
"")

+ добавил вариант с сводной
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра