Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Главное меню

Сумирование массива по условию

Автор Мария Прохорова, 13.01.2019, 17:47

« назад - далее »

Мария Прохорова

Здравстуйте подскажите пожалуйста как выполнить следующие действия в exel.
Нужно просуммировать массив данных удовлетворяющих условию в столбце слева. Файл прилагаю. формула "суммесли" не работает. Только пожалуйста не надо писать простую формулу "сумм" с диапазоном суммируемых ячеек или выводить сумму по каждой строке в 1 столбец и складывать и т.д.
Здесь приведен урезанный формат данных, значений на самом деле очень много (к тому же столбцы будут добавляться...) и поэтому нужно чтобы суммировались все значения в диапазоне B:H, соответствующие определенному условию в столбце А (в файле указан пример).

_Boroda_

Так нужно?
=СУММПРОИЗВ((A$2:A$9999=2)*Ч(+B$2:H$9999))
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

boa

Цитата: Мария Прохорова от 13.01.2019, 17:47
Только пожалуйста не надо писать простую формулу "сумм" с диапазоном суммируемых ячеек
а почему нет?

=СУММ(ИНДЕКС(C2;ПОИСКПОЗ(RC11;C1;0)):ИНДЕКС(C8;ПОИСКПОЗ(RC11;C1;0)+СЧЁТЕСЛИ(C1;RC11)-1))
следующая покороче, но волотильная.
=СУММ(СМЕЩ(R1C1;ПОИСКПОЗ(RC11;C1;0)-1;1;СЧЁТЕСЛИ(C1;RC11);7))
в RC11 - критерий
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

Мария Прохорова

Да Все так. Спасибо ОГРОМНЕЙШЕЕ за помощь!!!!!!!!!!!!!!!!!!!!!!
Только не подскажите еще как быть если нужно суммировать не все столбцы массива, а только первые и последние. Например: столбцы B:E и стобец H. Просто опять таки если я дважды вбиваю формулу через знак "+" с учетом суммируемых диапазонов, он опять выдает 0.
Заранее спасибо.

boa

Александра
=СУММПРОИЗВ((C1=RC11)*Ч(+C2:C5))
+СУММПРОИЗВ((C1=RC11)*Ч(+C8))

и мои две
=СУММ(СМЕЩ(R1C1;ПОИСКПОЗ(RC11;C1;0)-1;1;СЧЁТЕСЛИ(C1;RC11);4))
+СУММ(СМЕЩ(R1C1;ПОИСКПОЗ(RC11;C1;0)-1;7;СЧЁТЕСЛИ(C1;RC11);1))

=СУММ(ИНДЕКС(C2;ПОИСКПОЗ(RC11;C1;0)):ИНДЕКС(C5;ПОИСКПОЗ(RC11;C1;0)+СЧЁТЕСЛИ(C1;RC11)-1))
+СУММ(ИНДЕКС(C8;ПОИСКПОЗ(RC11;C1;0)):ИНДЕКС(C8;ПОИСКПОЗ(RC11;C1;0)+СЧЁТЕСЛИ(C1;RC11)-1))
Ничто не обходится нам так дешево и не ценится так дорого, как вежливость...  Мигель Сервантес де Сааведра

_Boroda_

=СУММПРОИЗВ((A$2:A$9999=2)*(Ч(+B$2:H$9999)*{1;1;1;1;0;0;1}))
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995