Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Поиск значений по условию и вывод соседних в строку

Автор Татьяна Алексеева, 31.01.2019, 12:34

« назад - далее »

Татьяна Алексеева

Уже несколько месяцев решаю периодически возникающую передо мной задачу всякими непродуктивными способами с использованием кучи формул, копированием/вставкой данных, снова формул...
Очень надеюсь, что все же существует способ быстро и легко сделать следующее:
найти текстовые значения совпадающие с искомым и вывести содержимое соседних в ячейки строки (или в одну ячейку с последующим разбитием по столбцам).

Допустим, есть столбец А - "марка", столбец В - "модель", столбец С - "производитель". Марки подразделяются на модели, для одинаковых моделей может быть много производителей.
На другом листе столбцы А -"марка" и В - "модель", их сочетания не повторяются. Нужно в строки с маркой и моделью вывести всех производителей с первого листа.

runner


Татьяна Алексеева

#2
О, спасибо! Так уже лучше. Как бы теперь это перевести в нужный вид.

runner

а чего не хватает?
нарисуйте на паре брендов, моделей и поставщиков как должно выглядеть, а то в приложенном файле поля значений пустые.
Обязательно ли заголовки - Производитель_1, Производитель_2 и т.д.?

_Boroda_

Если формулами и с учетом того, что исходная таблица скорее всего достаточно большая (то есть классическая комбинация ИНДЕКС + НАИМЕНЬШИЙ все повесит) предложу выводить данные в обратном порядке вот такой формулой
=ЕСЛИОШИБКА(ПРОСМОТР(;-1/($A2=Лист1!$A$2:$A$999)/($B2=Лист1!$B$2:$B$999)/ЕНД(ПОИСКПОЗ(Лист1!$C$2:$C$999;$B2:B2;));Лист1!$C$2:$C$999);"")
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Татьяна Алексеева

Цитата: runner от 31.01.2019, 15:29
а чего не хватает?
нарисуйте на паре брендов, моделей и поставщиков как должно выглядеть, а то в приложенном файле поля значений пустые.
Обязательно ли заголовки - Производитель_1, Производитель_2 и т.д.?

нарисовала как должно выглядеть
Заголовки не обязательны

Татьяна Алексеева

#6
Boroda_, да, таблица почти 3000 значений, 28 производителей.
Вставила все значения, подправила диапазон и ВСЕ работает.

Вы - гений! Спасибо!
Сейчас немножко благодарности переведу на счет :-)

_Boroda_

Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995