Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Значение из ячейки по формуле из другой ячейки

Автор sbm78, 15.10.2021, 21:48

« назад - далее »

sbm78

Подскажите, в ячейках Листа2, ссылки на ячейки столбца С Листа1: =Лист1!С3, =Лист1!С15, =Лист1!С21 и др.
Как написать формулу, чтобы получить значение соответствующих ячеек из столбца А Листа1, т.е =Лист1!А3, =Лист1!А15, =Лист1!А21 и т.д.

т.е. в ячейке ссылка на другую ячейку, надо из этой ссылки определить строку и столбец и получить значение в этой строке, но на 2 столбца левее
значения могут повторяться, поиском не получится

Serge 007

Здравствуйте

Для вашего примера:=ИНДЕКС(Лист1!A$1:C$7;ПРАВБ(Ф.ТЕКСТ(A2);ДЛСТР(Ф.ТЕКСТ(A2))-8);КОДСИМВ(ПСТР(Ф.ТЕКСТ(A2);ПОИСК("!";Ф.ТЕКСТ(A2))+1;1))-64-2)
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390