Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Счет значений между двумя датами

Автор alfatboy, 10.02.2022, 13:14

« назад - далее »

alfatboy

Добрый день!
Нужна помощь.
В таблице необходимо подсчитать количество значений за определенный период между двумя конкретными датами (выделены красным).
В ст.А значения
В ст.В даты
В ст.D прописал формулу, но расчет ведется неверно.
Отчетный период указан в ст.E и ст.F.
Образец во вложении.
Перевод в формат "умной таблице" не подходит.

Serge 007

Здравствуйте

Сколько должно получиться в примере и почему?
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

alfatboy

В примере в столбце А "Значения" между датами 02.02.2022 и 08.02.2022 должно получиться 14.
Счет должен быть количества ячеек между датами.
Вместо цифр в ст.А "Значения" указываются разные данные, мне нужно посчитать именно их количество.

Serge 007

Цитата: alfatboy от 10.02.2022, 14:43...между датами 02.02.2022 и 08.02.2022 должно получиться 14...
=СУММПРОИЗВ((B2:B25>=E2)*(B2:B25<=F2)*(A2:A25<>""))
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

alfatboy

Огромное спасибо!
Добавил еще несколько условий для подсчета, все работает отлично!!!