Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Про А1 и В1

Автор BSI52, 09.04.2023, 17:42

« назад - далее »

BSI52

Всем привет! Я не спец  в премудростях Excel, но нужен ответ, помогите. В А1 живет Вася А1=Вася, в В1 живет Петя В1=Петя, Вася с Петей могут меняться местом жительства (иногда в А1 может жить Петя, а в А1 иногда может жить Вася). Надо написать формулу Если в А1=Вася и в В1=Петя  получилось "Они не знакомы", далее тут же в формуле Если А1=Петя и В1=Вася получилось "Они переехали" далее в формуле А1= Вася и В1=Вся получилось "Петя ушел к Маше". Результат в ячейку D1. Всем ответившим спасибо. ;D

BSI52

Если непонятно описал. Высылаю файл.

BSI52

Спасибо, что посмотрели. Ответ я уже нашел. Пока-пока.

Serge 007

Здравствуйте

Вариант:=ВЫБОР((A1="Вася")*(B1="Петя")+(A1="Петя")*(B1="Вася")*2+(A1="Вася")*(B1="Вася")*3;"Они не знакомы";"Они переехали";" Петя ушел к Маше")
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

elovkov

Цитата: BSI52 от 09.04.2023, 17:42Если в А1=Вася и в В1=Петя  получилось "Они не знакомы", далее тут же в формуле Если А1=Петя и В1=Вася получилось "Они переехали" далее в формуле А1= Вася и В1=Вся получилось "Петя ушел к Маше". Результат в ячейку D1. Всем ответившим спасибо. ;D
Самое интересное, что формула через ЕСЛИ уже написана, даже функция И есть)))
=ЕСЛИ(И(A1="Вася";B1="Петя");"Они не знакомы";ЕСЛИ(И(A1="Петя";B1="Вася");"Они переехали";ЕСЛИ(И(A1="Вася";B1="Вася");" Петя ушел к Маше";"")))Это я так, без претензий на гениальность формулы, просто улыбнуло)
Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица. Улыбайтесь, господа, улыбайтесь!

Serge 007

Цитата: elovkov от 10.04.2023, 12:11формула через ЕСЛИ уже написана
Поэтому интереснее написать что-то необычное, например  так:
=ВПР(A1&B1;{"ВасяПетя";1:"ПетяВася";-1:"ВасяВася";0};2;)или так:
=ПОИСКПОЗ(A1&B1;{"ПетяВася":"ВасяВася":"ВасяПетя"};)-2и использовать пользовательский формат ячеек :)


Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

elovkov

Цитата: Serge 007 от 10.04.2023, 12:49и использовать пользовательский формат ячеек
Интересно, да. Но я так понимаю для более сложных взаимоотношений Пети и Васи (>3 вариантов) это уже не подойдет? ;D
Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица. Улыбайтесь, господа, улыбайтесь!

Serge 007

Формат да, не пойдет, разумеется  :D
А вот ВПР можно использовать для большого количества отношений без какого-либо ущерба для "читаемости" формулы
В отличии от громоздких множественных вложенных ЕСЛИ  ;) 
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390