Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

просуммировать по условию с функцией массива

Автор Антон1984, 20.04.2023, 22:17

« назад - далее »

Антон1984

Добрый день.
помогите пожалуйста, никак не могу просуммировать значения в столбце С  по условию, если по столбцу артикул есть совпадения по столбцам аналог, то сумму считаем из столбца кол-во.
пример во вложении, первую позицию посчитал руками.Дима.xlsxДима.xlsxДима.xlsx   

Pelena

Здравствуйте.
Если правильно поняла
=СУММПРОИЗВ(ЕЧИСЛО(ПОИСК(D2;$E$2:$FW$784))*$B$2:$B$784)

Антон1984

не совсем так, в строке 5 правильно считает, а в 30 нет. Данные позиции аналоги и кол-во должно быть одинаковым.Дима.xlsx позиции выделил желтым

Serge 007

Цитата: Антон1984 от 21.04.2023, 08:47Данные позиции аналоги
Как это понять и дать знать Excel?
Артикулы-то у них разные:
DX4-1013
DX4-1013C

Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Антон1984

#4
по артикулу DX4-1013 в строке аналог есть артикул DX4-1013C и наоборот

Serge 007

Давайте попробуем формулой массива:
=СУММ(ЕЧИСЛО(ПОИСК(D2;E$2:F$7))*B$2:B$7)+(СЧЁТ(НАЙТИ(D2;E$2:F$7))=1)*B2
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Антон1984