Фильтрация сводной таблицы по набору значений соответствующих выбору

Автор gregory9791, 08.09.2023, 10:56

« назад - далее »

gregory9791

Имеется: таблица наличия продуктов на складе с признаком "контракт",
а также справочная таблица соответствия контрактов конкретным менеджерам (с возможностью дополнения).

Задача: сформировать сводную таблицу и отфильтровать ее для конкретного менеджера. Например,выбираем из списка менеджера "Иван" и сводная отфильтровывается по номерам контрактов соответствующих менеджеру "Иван".Пример данных для фильтрации.xlsx

buchlotnik


gregory9791

На моём Excel2010 не работает, выдаёт ошибку "Сбой инициализации источника данных..."

buchlotnik

Цитата: gregory9791 от 12.09.2023, 08:37На моём Excel2010
ну так вы же не предупредили о версии, модель данных появилась в 2013

gregory9791


Serge 007

А если без макроса, но с допстолбцом и ВПР? (см. вложение)
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

gregory9791

#6
Сергей, большое спасибо!
Вполне рабочий вариант.
Ранее не был знаком с таким приёмом, как формирование таблицы для функции из отдельных столбцов: =ВПР(ТЕКСТ(C3;"000");I$3:J$20&K$3:L$20;2;)Спасибо за науку!

Serge 007

Цитата: gregory9791 от 26.09.2023, 08:41формирование таблицы для функции из отдельных столбцов
Там немного другое ;)
Фактически - это смена столбцов местами, например, столбец А перемещается на место столбца В и наоборот
Но происходит это в виртуальной памяти, а не на листе
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

gregory9791

Да, я заметил смену столбцов и проще было бы в исходной табличке-справочнике поменять местами столбцы, но мастера не меняют исходные данные и красиво решают даже такие закавыки и при этом обучают ;)