Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Суммирование ячеек по столбцам по дате

Автор Dmitry Z, 25.10.2023, 00:23

« назад - далее »

Dmitry Z

Добрый день.
На первом листе "Данные" есть строка с датой и строка со значением, соответствующим этой дате.
На второй лист "Результат" нужно сумму значений из Листа "Данные", соответствующие месяцу.

Осложняется всё тем, что данные не в строках, а в столбцах
Желательно решение формулой, без макросов и сводных таблиц.
Благодарю за идеи.

Serge 007

Здравствуйте

В рамках года:=СУММПРОИЗВ((МЕСЯЦ(B1)=МЕСЯЦ(Данные!$B1:$H1))*Данные!$B2:$H2)
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Dmitry Z


Katherine_

Добрый день.
Позвольте вопрос в продолжение данной темы.

Нужно посчитать выручку только за август (в столбце данные в формате 01.08.2023)
Начинаю так, но не пойму как отразить месяц:
=СУММПРОИЗВ(C9:C23*(МЕСЯЦ(A9:A23 = .....))

Заранее спасибо

Serge 007

Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Katherine_

Странно, что пробовала так - не отрабатывало  :-[
Спасибо!!!