Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

суммирование в ячейке по содержимому нескольких ячеек с выбором в другом файле

Автор Antopol, 23.11.2023, 13:21

« назад - далее »

Antopol

добрый день,

прошу помощи, нужно посчитать в столбце S и T. выбрать из таблицы с остатками совпадающими со значениями в столбцах M и N и сложить их значения "кол-во" сначала без критерия характеристика в столбец S, далее тоже самое, только добавляется условие совпадения столбца СП с таблицы "Свод" столбцу характеристика таблицы остатки, результат указывается в столбце T.для заявок 2024.zip

Serge 007

Здравствуйте

Ничего непонятно...
Куча лишней информации
Сделайте один файл - два листа по пять строчек и только те столбцы, которые нужны для решения задачи
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Antopol

Доброго времени суток,

В столбце G должно суммироваться кол-во с листа "Остатки" соответствующее содержимому ячеек E и F в столбце A в остатках.
В столбце H должно суммироваться кол-во с листа "Остатки" соответствующее содержимому ячеек E и F в столбце A в остатках, и значение столбца A в заявке должно совпадать с совпадать с значение столбца C в остатках.

Вроде понятно.

Serge 007

Так надо?
=СУММЕСЛИ(Остатки!A$2:A$42;E2;Остатки!C$2:C$42)+СУММЕСЛИ(Остатки!A$2:A$42;F2;Остатки!C$2:C$42)
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Antopol

Добрый день, так у меня не получилось, появились доп условия и пришлось сделать массивом. значения поиска разной длины от 4-х до 6-и символов, иногда спереди есть "*". формула ниже с ячейки G2. CTRL+SHIFT+ENTER
=СУММ((ЕСЛИОШИБКА(ПОИСК(СЦЕПИТЬ(СИМВОЛ(10);ПОДСТАВИТЬ(Остатки!$A$2:$A$42;"*";"уд");СИМВОЛ(10));СЦЕПИТЬ(СИМВОЛ(10);ПОДСТАВИТЬ('Заявка 2024г'!E2;"*";"уд");СИМВОЛ(10);ПОДСТАВИТЬ(F2;"*";"уд");СИМВОЛ(10));1);0)>0)*Остатки!$C$2:$C$42)

Antopol


Serge 007

Вы нормально объяснить задачу можете?
Каждый Ваш пост противоречит предыдущим

PS Теги используйте при оформлении формул
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390