Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Расшифровка биллинга оператора по заданным критериям

Автор Beat, 21.01.2024, 15:50

« назад - далее »

Beat

Здравствуйте. Начальство дало задание вычленить из биллинга, предоставленного оператором связи (см. файл "Пробный"), в новый лист "Расшифровка" данные исходящих звонков каждого абонента по следующим критериям:
1. Звонки на абонентов сотового оператора Билайн - отдельно (длительность и стоимость);
2. Звонки на всех остальных сотовых операторов - отдельно (длительность и стоимость);
3. Межгородские и междугородние звонки - отдельно (длительность и стоимость).

По оператору Билайн у меня получилось по формуле =СУММЕСЛИМН(F5:F5000;$A$5:$A$5000;"*1120000"; $B$5:$B$5000;"Билайн")
По другим операторам и направлениям отдельно не получается. Помогите пожалуйста, в Exel у меня мало опыта.
P.S. Решено выносом сотовых операторов в отдельный список, подсказали на другом форуме.

elovkov

Добрый день, Вашей же формулой можно остальных операторов посчитать
=СУММЕСЛИМН($F$5:$F$5000;$A$5:$A$5000;"*1120000"; $B$5:$B$5000;{"МТС";"Теле2";"Мегафон"})Ну а межгород как я понимаю просто вычесть мобильные из общей суммы
Ну и удобнее наверное не часть номера в формуле прописывать, а сослаться на ячейку с номером
=СУММЕСЛИМН($F$5:$F$5000;$A$5:$A$5000;I3; $B$5:$B$5000;{"МТС";"Теле2";"Мегафон"})
Умное лицо это еще не признак ума. Все глупости на земле делаются именно с этим выражением лица. Улыбайтесь, господа, улыбайтесь!

Serge 007

Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390