Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Главное меню

Вставка в формулу с диапазоном значений данных из ячейки

Автор alfatboy, 20.02.2024, 10:38

« назад - далее »

alfatboy

Добрый день!
Есть база данных с большим количеством значений на отдельном листе необходимо делать суммирование по определенному виду.
В приложенном примере на "Лист 1" подсчет идет с "Лист 2" по формуле "=СУММЕСЛИ(Лист2!$A$3:$A$5;$A2;Лист2!B3:B5)". Необходимо, чтобы в данной формуле значения в диапазон Лист2!B3:B5 вставлялись из строки "переменная". Данные в строке переменная мне необходимо менять на указанные ниже "февраль", "март" и т.д.

Заранее спасибо.

Serge 007

Здравствуйте

В А7 пишете месяц:
=ИНДЕКС(Лист2!$B3:$AE3;;ПОИСКПОЗ($A7;Лист2!$B1:$AE1;)+СТОЛБЕЦ()-2)
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

alfatboy

Спасибо, но не совсем то.
Забыл указать, что на "Лист 2" строк со значением "СВ" много и нужно посчитать данные по всем "СВ".
Пример во вложении.
Также в "Лист 2" я не могу вносить ни какие изменения он по умолчанию заблокирован.

_Boroda_

Так нужно?
=СУММЕСЛИ(Лист2!$A$3:$A$99;$A$2;ИНДЕКС(Лист2!B$3:$DQ$3;;10*МЕСЯЦ($A4&1)-9))
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

alfatboy