Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Определение номера строки в массиве ячеек содержащих определенный текст

Автор gregory9791, 01.07.2024, 16:57

« назад - далее »

gregory9791

Добрый день, форумчане.

Есть текстовый массив A1:B5. В тексте одной из ячеек которого есть слово "письмо" либо слово "заявка".
Необходимо определить номер строки содержащий любое из этих слов.
Пробовал так: =ИЛИ(ЕЧИСЛО(ПОИСК("Заявка";A1:B5));ЕЧИСЛО(ПОИСК("письмо";A1:B5)))*СТРОКА(A1:B5) Но, что-то не работает.

Hugo121

=ПОИСКПОЗ("*заявка*";A1:A5;0) и прикрутить через если() или или() поиск письма
Вернее так - сперва ищем зяавку, если не нашли то письмо:
=ЕСЛИОШИБКА(ПОИСКПОЗ("*заявка*";A1:A5;0);ПОИСКПОЗ("*письмо*";A1:A5;0))
webmoney: E265281470651 Z422237915069

gregory9791

Текстовый массив двумерный, и данные формулы не работают.

Hugo121

webmoney: E265281470651 Z422237915069

gregory9791

Слова "заявка" и "письмо" могут быть и в столбце "B" и тогда формула не сработает

N_Dvorets


Hugo121

Цитата: gregory9791 от 02.07.2024, 10:50Слова "заявка" и "письмо" могут быть и в столбце "B" и тогда формула не сработает
сработает такая:
=ЕСЛИОШИБКА(ПОИСКПОЗ("*заявка*";A1:A5&B1:B5;0);ПОИСКПОЗ("*письмо*";A1:A5&B1:B5;0))
webmoney: E265281470651 Z422237915069

gregory9791

Цитата: Hugo121 от 02.07.2024, 11:39сработает такая:
=ЕСЛИОШИБКА(ПОИСКПОЗ("*заявка*";A1:A5&B1:B5;0);ПОИСКПОЗ("*письмо*";A1:A5&B1:B5;0))
Да, все работает (если вводить в форме массива). Большое спасибо!

gregory9791

Цитата: gregory9791 от 02.07.2024, 15:05Да, все работает (если вводить в форме массива). Большое спасибо!
Тоже отличный вариант, возьму на вооружение.
Спасибо!

Hugo121

Поправочка - так надёжнее:
=ЕСЛИОШИБКА(ПОИСКПОЗ("*заявка*";A1:A5&"|"&B1:B5;0);ПОИСКПОЗ("*письмо*";A1:A5&"|"&B1:B5;0))Это для значений типа
фвазая   вка
webmoney: E265281470651 Z422237915069

gregory9791

Цитата: N_Dvorets от 02.07.2024, 11:01Вариант с пользовательской функцией.Пример поиска строки содержащей текст.xlsm
А можно ли преобразовать эту функцию так, чтобы она искала как текст, так и значение которые выглядят одинаково. Например, 111 - как текст и 111 как число.

N_Dvorets

ЦитироватьА можно ли преобразовать эту функцию так, чтобы она искала как текст, так и значение которые выглядят одинаково.
Можно. Но что должна сделать эта функция в каждом из этих вариантов?

Hugo121

webmoney: E265281470651 Z422237915069

N_Dvorets

Цитировать-  As Integer не годится, в Экселе намного больше строк...
Мы не знаем реальный размер массива данных. В случае проблем подойдет As Long.

gregory9791

Цитата: N_Dvorets от 03.07.2024, 17:17Но что должна сделать эта функция в каждом из этих вариантов?
Задача функции та же - найти номер строки содержащий либо текст "111" либо число "111".