Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

ДВОЙНОЙ ВПР

Автор Elavio, 27.01.2011, 21:21

« назад - далее »

Elavio

Добрый вечер всем!

Хочу спросить совета у более опытных пользователей .

Есть таблица с артикулами и уровнями упаковки на листе 1 и есть таблица на листе 2 ю
Нужно перекинуть данные с таблице на листе 1 в таблицу на листе 2.

Думаю,это можно сделать через ВПР по двум условиям (чтоб сначала искал артикул ,потом уровень упраковки и на совпадении показивал данные из нужного столбца) но пока не получилось....

Файл прилагаю

Serge 007

Здравствуйте.
Всё очень просто:
=ИНДЕКС(Лист1!$C$4:$C$70;ПОИСКПОЗ(A4&B4;Лист1!$A$4:$A$70&Лист1!$D$4:$D$70;0))
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Elavio

Спасибо ,но чуть наверное не так

Мне надо ,что б в столбец базовая единица подтягивало шт ,тоесть данные с листа 1 столбец J

И все остальные данные в том же духе ,тоесть чтоб по каждому артикулу в таблицу 2 подтягивались параметры по каждому уровню ....

_Boroda_

Так?
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Elavio


Вроде ,так ,еще проверю , спасибо большое

А существует (в принципе ) ВПР по двум условиям ?

Serge 007

Цитата: Elavio от 27.01.2011, 21:44
А существует (в принципе ) ВПР по двум условиям ?
Нет. Только ЮДФ-ки.

ЦитироватьМне надо ,что б в столбец базовая единица подтягивало шт ,тоесть данные с листа 1 столбец J
Ну так надо указать необходимый диапазон в ИНДЕКС().
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Elavio

Еще вопросик по файлу,если я перенесу с таблицы 2 -самую верхнюю строку ,там где 0000 1111 в первую таблицу ,по данной формуле можно будет посчитать ?

У меня что-то не идет...(((

Elavio

Извиняюсь за неученость и за трату времени на меня ,что такое ЮДФ-ки ?

Serge 007

Цитата: Elavio от 27.01.2011, 21:57
Извиняюсь за неученость и за трату времени на меня ,что такое ЮДФ-ки ?
Юзер Дефинишн Функшн. Короче функция написанная самим пользователем.
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

_Boroda_

ЦитироватьЕще вопросик по файлу,если я перенесу с таблицы 2 -самую верхнюю строку ,там где 0000 1111 в первую таблицу ,по данной формуле можно будет посчитать ?

У меня что-то не идет...(((
А зачем? Поставьте шрифт белым и их не видно будет
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Elavio

Понятно.

У меня новая проблема,не могу прописать данную ф-цию в столбе базовая единица .............

Файл додаю

Elavio

Неа,закрасите не пойдет ,мне потом етот лист нужен будет для импорта в другую программу  и на нем должна быть только таблица

Решил по другому-вырезал и вставил на первом листе

_Boroda_

А что туда тянуть нужно? какой столбец из листа 1?
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Serge 007

У Вас не столбца "Базовая единица" на Лист 1.
Поэтому используйте =ИНДЕКС(Лист1!$E$4:$E$70;ПОИСКПОЗ($A4&Лист1!L$3;Лист1!$A$4:$A$70&Лист1!$B$4:$B$70;0)).
Не забываем про Ctrl+Shift+Enter :)
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Elavio

Что то не так,оно все "1" выставило

Хочу что б со стобца "J" (10 столбец) тянуло в столбец базовая единица на листе 2 ,тоесть в идеале у всех там должно быть "шт"