поискпозиции

Автор iron priest, 13.02.2011, 20:08

« назад - далее »

iron priest

здравствуйте

подскажите можно ли найти позицию по 2-м критериям? по одному знаю как  индекс (ляля. поискпозии(ляля)ляля)

а у меня задача стоит такая. есть наименование ТМЦ и № калькуляции, нужно найти позицию соответствующую этим критериям

небольшой пример


iron priest

вроде такое работает

=ВПР(ДВССЫЛ("A"&ПОИСКПОЗ(продукция&калькуляция;искомая продукция&искомая калькуляция;0);ИСТИНА);A:A;1;ЛОЖЬ)

возвращает номер по порядку, а вот чтото с гиперссылкой не получается...

Serge 007

Чёт не понял по каким критериям совпадения должны быть...
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

iron priest

ладно черт с ним, а какой формулой суммирование можно воспользоваться?

пример

счет сумма
201 50
206 30
25 48

нада суммировать только счета 20*. результат =80

iron priest

пришлось перегонять все счета в текстовый формат...

ZORRO2005

Цитата: iron priest от 14.02.2011, 13:28
пришлось перегонять все счета в текстовый формат...
Да, если перегнать в текстовый то:
=СУММЕСЛИ(A1:A3;"20*";B1:B3)
а если не хочешь перегонять:
=СУММ((ЛЕВСИМВ(A1:A3;2)*1=20)*B1:B3)
Яндекс-деньги: 410011658492153

iron priest