Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Главное меню

сравнение в столбец

Автор olimpus, 25.02.2011, 13:06

« назад - далее »

olimpus

Здравствуйте
Подскажите формулу сравнения с такими условиями
Начну с того что это сводная таблица

Допустим в заголовке строки 1 идут названия месяцев и год
В столбце "В" идут названия экономических индикаторов, а под месяцами их значения
И допустим индикатор в ячейке "B10" выходит 1 раз в месяц , и сравнение происходит в ячейке "ВС10" просто последнее значение в строке сравниваем с предыдущим и выдает
"К" если последнее значение меньше предыдущего и
"З" если последнее значение больше предыдущего
Но
Индикатор в ячейке "В14" выходит 1 раз в неделю в четверг
Четвергов в месяце бывает иногда 4 , а иногда 5
Выход нашел такой просто пронумеровал выход индикатора в столбец
т.к в строку не получается
И теперь нужно сравнивать последнее значение в столбец
а не в строку как индикатор в ячейке "В10"
Прошу заметить что в 18 строке есть пропуски , значит если отсутствует предыдущее значение то нужно сравнить с ближайшим

Михаил С.

Отдельное спасибо можно на QiWi-кошелек 909-771-53-87 или ЯД 41001136675053

olimpus

Формула нужна для условного форматирования в столбце "В" по формуле =$BC14="к"(Красный) и =$BC14="з"(Зеленый)
Раньше все в таблице закрашивал от руки пока разбирался как она работает , сейчас разобрался и нужно чтоб она закрашивалась автоматически
Формулу в ячейке "ВС14" можно немного подкрутить?
Допустим ячейка "СО14" сравнивается с ячейкой "CN18"и если там нет значения то она ищет ближайшее значение в этом же столбце, тоесть сравнивается с ячейкой  "CN17"



Михаил С.

#3
Цитата: olimpus от 26.02.2011, 17:04
Формулу в ячейке "ВС14" можно немного подкрутить?
Допустим ячейка "СО14" сравнивается с ячейкой "CN18"и если там нет значения то она ищет ближайшее значение в этом же столбце, тоесть сравнивается с ячейкой  "CN17"
Не знаю, как, но там (в "BC14") вкралась ошибка.. :( должно быть
=ЕСЛИ(ПРОСМОТР(9^9;CE14:CZ14)>ПРОСМОТР(9^9;ИНДЕКС(CE14:CZ18;;ПОИСКПОЗ(9^9;CE14:CZ14)-1));"З";"К")
или
=ЕСЛИ(ПРОСМОТР(9^9;CE14:CZ14)>ПРОСМОТР(9^9;ИНДЕКС(CE14:CZ18;;ПОИСКПОЗ(9^9;CE14:CZ14)-1));"З";"К")

_____

ps.
Если для УФ, то можно проще:
=ПРОСМОТР(9^9;CE14:CZ14)>ПРОСМОТР(9^9;ИНДЕКС(CE14:CZ18;;ПОИСКПОЗ(9^9;CE14:CZ14)-1)) для зеленого и
=ПРОСМОТР(9^9;CE14:CZ14)<ПРОСМОТР(9^9;ИНДЕКС(CE14:CZ18;;ПОИСКПОЗ(9^9;CE14:CZ14)-1))для красного

Ну и другие соответственно.
Отдельное спасибо можно на QiWi-кошелек 909-771-53-87 или ЯД 41001136675053

Михаил С.

Отдельное спасибо можно на QiWi-кошелек 909-771-53-87 или ЯД 41001136675053

olimpus

 покажите еще формулу для условного форматирования для индикатора "В10" где сравнивает в строку , и как в предыдущей формуле надо учесть что  будут пропуски значений

Михаил С.

Нарисуйте маленькую табличку, раскрасьте, как хотите видеть. Только учтите, что в 2003 в УФ возможно только три условия на  диапазон.
Отдельное спасибо можно на QiWi-кошелек 909-771-53-87 или ЯД 41001136675053

olimpus

Допустим ячейку "CJ10" надо сравнить и закрасить по сравнению  с предыдущей ячейкой
по такому условию
если расмариваемая ячейка больше предыдущей тогда тогда окрашивается в зеленый
если расмариваемая ячейка меньше или равна  предыдущей  тогда окрашивается в красный

надо учесть что могут быть пропуски значений

Михаил С.

Отдельное спасибо можно на QiWi-кошелек 909-771-53-87 или ЯД 41001136675053

olimpus

Спасибо все отлично
У меня последний вопрос
Есть диапазон BC10:BC25 , там находятся определенное колличество букв  "К" и "З"
Допустим ячейка BC30 считает колличество букв"К"
               ячейка BC31 считает колличество букв"З"
             
В ячейке BC32 нужно посчитать колличество букв"З" в процетах от общего диапазона , тоесть BC10:BC25
В ячейке BC33 нужно посчитать колличество букв"К" в процетах от общего диапазона , тоесть BC10:BC25

Михаил С.

Без учета пустых ячеек:
для "К"=СЧЁТЕСЛИ(BC10:BC29;"К")/СЧЁТЗ(BC10:BC29)
для "З" =СЧЁТЕСЛИ(BC10:BC29;"З")/СЧЁТЗ(BC10:BC29)

С учетом пустых
для "К"=СЧЁТЕСЛИ(BC10:BC29;"К")/ЧСТРОК(BC10:BC29)
для "З" =СЧЁТЕСЛИ(BC10:BC29;"З")/ЧСТРОК(BC10:BC29)

если диапазон - строка, то вместо ЧСТРОК() пишем ЧИСЛСТОЛБ().
Для двумерного массива - ЧСТРОК()* ЧИСЛСТОЛБ().
Отдельное спасибо можно на QiWi-кошелек 909-771-53-87 или ЯД 41001136675053

olimpus

#11
Михаил посмотрите  формулы ,почемуто  дает не тот результат временами
Первая формула показывает правильно , а четыре нижних ошибаются