Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

Максимальное значение при заданном условии

Автор erd_2002, 25.02.2011, 16:13

« назад - далее »

erd_2002

Помогите, пожалуйста, решить следующую задачу:
имеется диапазон данных, из которых нужно найти максимальное значение, которое будет меньше или равно параметру, изменяющемуся по годам.


_Boroda_

Если я правильно понял условия, то так:

=ИНДЕКС($B$2:$N$2;ПОИСКПОЗ(B3;$B$2:$M$2;-1)+1)
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

erd_2002

Ух ты! Здорово! Спасибо большое!!!

Я пыталась прописать функцию с помощью VBA, именно через поиск максимального значения, но, видимо, что-то некорректно задавала.....


Спасибо