Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

Найти бы константы и сделать бы формулу

Автор symbio, 13.03.2011, 10:30

« назад - далее »

symbio

Привет! Идея есть! Данные тоже! Образец тоже.
тут просто вывести формулу из этих данных
может типа будет
Rain=Const(1)+Temp*Const(2)
Надо решить уравнение
значения тут в таблице

В красной строке темп (начинается от 1 градуса), в зеленой значения которые которые есть при 1 градусе.
Должно получатся В одном варианте такие цифры как в белых ячейках с одной стороны! А если менять цифры которые в зеленом на противоположный знак напр., с 5 на -5 то должны получится с другой стороны. Надо найти обе константы.
С можете помочь. Но очень большая просьбя, только не макросом!
Я просто сам не много слаб!
Формула типа:
220=Const(1)+1*Const(2)
215=Const(1)+2*Const(2)

Михаил С.

Вам бы в правила... да и вопрос чуть по-понятнее задать...
Отдельное спасибо можно на QiWi-кошелек 909-771-53-87 или ЯД 41001136675053

symbio

#2
Цитата: Михаил С. от 13.03.2011, 11:20
Вам бы в правила... да и вопрос чуть по-понятнее задать...
Я это как бы знаю, но разве тут не помогают! И как бы образец формулы привел!
Rain=Const(1)+Temp*Const(2)
Обе константы надо подобрать! Чтобы получились такие цифры как в белом.

VictorK

Цитата: symbio от 13.03.2011, 11:25
Я это как бы знаю, но разве тут не помогают! И как бы образец формулы привел!
Rain=Const(1)+Temp*Const(2)
Обе константы надо подобрать! Чтобы получились такие цифры как в белом.
Для 1, 2, 3 и 6-й строк в левой половине таблицы подойдёт следующая формула:
1-я ячейка строки Fronte    =$M4*45+B$3*(-$M4)   (растянуть вправо) где $M4 - значение из зеленого столбца, B$3 - значение из красной строки.
1-я ячейка строки Aizmugur =$M5*45+B$3*(-$M5)   также растянуть формулу по строке вправо.
Подобным образом эта формула подходит и для 3-й и 6-й строк.

А вот для значений в 4-й строке (Apstāt) константы подобрать не удалось, решение не найдено.
Для значений 5-й строки (draba) формула будет уже немного другая:
=$M8*0+B$3*$M8

PS Решения нашёл на сайте http://www.math-pr.com/equations_1.php (Решение системы M линейных уравнений с N неизвестными), подставлял ваши значения из таблицы, получил константы, заметил зависимость констант от значений в зеленом столбце, осталось только написать формулу, которая, как выше отметил, подошла не для всех строк.
А для правой половины таблицы формулы такие-же, только со знаком минус.

symbio

ЦитироватьVictorK
Вы гений! А четвертей строке я нашел.
=$M7*50+B$3*(-$M7)
И все получилось!
Удачи Вам! И если что надеюсь Вы поможете!  :D

VictorK

Цитата: symbio от 13.03.2011, 16:03
ЦитироватьVictorK
Вы гений! А четвертей строке я нашел.
=$M7*50+B$3*(-$M7)
И все получилось!
Удачи Вам! И если что надеюсь Вы поможете!  :D
Да какой я гений ;) я в 1979 году ПТУ закончил и больше никакого образования.
Просто задачка интересной показалась.

symbio

Цитата: VictorK от 13.03.2011, 16:05
Да какой я гений ;) я в 1979 году ПТУ закончил и больше никакого образования.
Просто задачка интересной показалась.
Спасибо за отзывчивость!

VictorK

Цитата: symbio от 13.03.2011, 11:25
Rain=Const(1)+Temp*Const(2)
Обе константы надо подобрать! Чтобы получились такие цифры как в белом.
Немного подумал и решил, что каждый раз искать решение (константы) на вышеприведенном сайте не совсем удобно.
Нужно заставить саму Excel вычислять эти константы в зависимости от данных.
Формулы для первой строки с данными следующие:
Const(1) =ИНДЕКС(ЛИНЕЙН($B4:$K4;$B$3:$K$3);2)
Const(2) =ИНДЕКС(ЛИНЕЙН($B4:$K4;$B$3:$K$3);1)

symbio

ЦитироватьConst(1) =ИНДЕКС(ЛИНЕЙН($B4:$K4;$B$3:$K$3);2)
Const(2) =ИНДЕКС(ЛИНЕЙН($B4:$K4;$B$3:$K$3);1)
В конце в обоих формулах откуда цифры 2 и 1?

Можешь подсказать мне тупому. Спасибо еще раз!

VictorK

Цитата: symbio от 14.03.2011, 17:54
В конце в обоих формулах откуда цифры 2 и 1?
Я эти формулы отыскал (совершенно случайно  ::) ) в справке Excel в описании функции ЛИНЕЙН.
Попробовал применить к твоей таблице и убедился, что они возвращают такие же значения, как и на том сайте по решению линейных уравнений.
1 и 2 относятся к функции ИНДЕКС и обозначают номер строки в массиве, из которой требуется возвратить значение.
В общем, лучше почитать описание функций ИНДЕКС и ЛИНЕЙН в справке Excel, я и сам пока толком не понимаю, как оно работает  :-[