Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

пересечение

Автор igroker, 20.03.2011, 12:35

« назад - далее »

igroker

Необходимо  подсчетать сколько раз   числа   в указанном диапазоне   пересекали  вверх    число 1,4361
а также сколько  раз  пересекали  вниз  число 1,3558
пример прилаю

igroker

важно именно если верх подсчитать  только пробой снизу вверх сколько раз  мне не нужен подсчет сколько раз число  вернулося обратно
тоже самое если вниз подсчитать пробой только  сверху вниз сколько  раз

MCH

Что значит "числа в указанном диапазоне пересекали вверх число 1,4361"?
Сколько получается таких "пересечений", если подсчитать вручную?
При каких ситуациях происходит пересечение, покажите на примере.

Сходу приходит только такой вариант (возможно не так понял):
=СУММПРОИЗВ((D2:D38<G1)*(D3:D39>=G1))

igroker

число 1,4361  является средним  первого диапазона       диапазон меняется  добавляется с новым месяцем  новая строчка сверху
число 1,3558  является средним  второго диапазона



nilem

Может, так?
=СЧЁТЕСЛИ(D2:D39;">="&G1)
=СЧЁТЕСЛИ(E2:E39;"<="&H1),
где ">=" - пересекли вверх, "<=" - пересекли вниз :)

igroker

эта формула  считает ,но она  суммирует пересечение как снизу вверх  так и  сверху вниз , а мне нужно только сколько раз пробило  снизу вверх   число 1,4361
тоже самое  для  числа 1,3558   но уже   счет только количество пробоев с вверху вниз.


iron priest

что за числа выделены отдельным форматированием?

igroker

=(СЧЁТЕСЛИ(D2:D39;">="&G1)-СЧЁТЕСЛИ(D2:D39;"<="&G1))/2    ответ 3 совпадает с ручным подсчетом
=СЧЁТЕСЛИ(E2:E39;"<="&H1)-СЧЁТЕСЛИ(E2:E39;>="&H1))/2         ответ 1  а ручный подсчет  дает 2
где моя ошибка
  а числа выделенные  это максимум  и минимум диапазона


iron priest

у меня вообще мозг кипит!

в колонке Д по идее должно быть 9 (все числа больше 1.4361 заканчивая ячейкой д33). а именно значения

1.4578
1.5141
1.5145
1.5061
1.4843
1.4447
1.4719
1.4867
1.5631




igroker

мы смотрим  колонки   D и Е снизу вверх
берем колонку D мне нужно только знать сколько раз   пересекло   число 1,4361 а несколько оно там находилось раз
после пересечения снизу вверх   число через определенное время опустилось ниже  потом  опять пересекло это число  потом опять  вернулось ниже   заданного числа  . мне нужен счет только сколько раз оно пересекло  снизу  и вверх.   и результат  такой вручную
3 раза оно пересекло снизу вверх  и 3 раза перескло сверху вниз.
тоже самое  для колонки E  но важно только пробой  сверху вниз  подсчет   и тут результат такой  в ручную  три раза  пересек 3 раза  сверху вниз  и 2 раза вернулся обратно    снизу вверх



igroker

Вот для колонки Е  первое пересечение сверху вниз   была  ячейка Е30  дальше  возврат Е22
второе пересечение  ячейка Е14      дальше возврат  ячейка Е6
  третье пересечение  ячейка Е5   возврата пока нет так  как число ниже 1,3558
итого три пересечения
нужна  формула для подсчета

MCH

Цитата: igroker от 20.03.2011, 15:37
мы смотрим  колонки   D и Е снизу вверх
берем колонку D мне нужно только знать сколько раз   пересекло   число 1,4361 а несколько оно там находилось раз
после пересечения снизу вверх   число через определенное время опустилось ниже  потом  опять пересекло это число  потом опять  вернулось ниже   заданного числа  . мне нужен счет только сколько раз оно пересекло  снизу  и вверх.   и результат  такой вручную
3 раза оно пересекло снизу вверх  и 3 раза перескло сверху вниз.
тоже самое  для колонки E  но важно только пробой  сверху вниз  подсчет   и тут результат такой  в ручную  три раза  пересек 3 раза  сверху вниз  и 2 раза вернулся обратно    снизу вверх
Так моя формула предложенная ранее так и считает.
Для колонки D:
=СУММПРОИЗВ((D2:D38<G1)*(D3:D39>=G1))
Для колонки E:
=СУММПРОИЗВ((E2:E38>H1)*(E3:E39<=H1))

ZORRO2005

#12
Согласен с МСН.
Яндекс-деньги: 410011658492153

igroker

спасибо   но еще  один вопрос
необходимо найти  найменьшее  число  из колонки D  которое больше   числа 1,4361
а также найти найбольшее число в колонке  E  которое меньше числа            1,3558
 

Serge 007

Цитата: igroker от 20.03.2011, 21:58
необходимо найти  найменьшее  число  из колонки D  которое больше   числа 1,4361
а также найти найбольшее число в колонке  E  которое меньше числа            1,3558
=МИН(ЕСЛИ(D2:D39>G1;D2:D39))
=МАКС(ЕСЛИ(E2:E39<H1;E2:E39))
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390