Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

добавление ограничений по множественным условия выбора значений

Автор algeka, 31.03.2011, 15:22

« назад - далее »

algeka

Добрый день,
Буду очень благодарна, если кто-то сможет помочь.

Делаю в excel таблицу-помощник, в которой при выборе вариантов в одной части, выдаются значения в другой.

Пользователи будут видеть только колонки А, B и табличку L1-N7.
В колонке B (yes\no) человек выбирает yes или no.
Если выбрано yes, то согласно формулам, заполняется табличка L1-N7.
Если No - ничего не происходит, как и если ничего не выбрано.
Это сейчас вроде нормально работает.
Но пока что у меня не получается добавить ограничения:
• В N1 должно быть только одно значение и, если человек выбирает yes для нескольких пунктов, где в колонке С есть значения, то, например, в O1 должно выдаваться предупреждение, что нужно выбрать только один вариант.
• Также в колонке J для некоторых подпроблем сформулированы специфические ограничения, при нарушении которых также должны выдаваться сообщения об ошибках.

Пробовала использовать функции IF, Or, но так как результаты в N1-N7 стоят не в виде конкретных значений, то добиться правильного решения мне не удалось

Шпец Докапыч

#1
O1: =ЕСЛИ(СУММПРОИЗВ((yon="yes")*(ДЛСТР(СМЕЩ(yon;;M1))>0))>1;"Предупреждение!";"")

Где yon - имя диапазона $B$9:$B$62 (yes or no).

Что касается специфических ограничений, то предлагаю выделять (не)соответствующие ячейки столбца "B" условным форматированием. Например, закрасить серым, чтобы не выбирали "yes" (если это допустимо). Скорее всего каждое ограничение выявляется простыми (одиночными) условиями, только вот из-за сокращённых формулировок не совсем понятно что имеется ввиду.
Знания недостаточно, необходимо применение. Желания недостаточно, необходимо действие. (с) Брюс Ли