язык текстовой строки

Автор Alexandr Zlobin, 01.04.2011, 16:02

« назад - далее »

Alexandr Zlobin

Здравствуйте! Подскажите, можно ли определять, написана ли строка по-русски или по-английский?
NULL

Serge 007

Здравствуйте.

Формулами можно, макросами думаю тоже можно.
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

ZORRO2005

#2
Формулами примерно так:
=ЕСЛИ(ИЛИ(КОДСИМВ(ПСТР(A1;СТРОКА(1:99);1))>122);"RUS";"ENG")
Если написано и по-русски и по-английски то формулу надо доработать.
Яндекс-деньги: 410011658492153

Prist

Как-то так можно определить, есть ли в формуле русские буквы:
=ЕСЛИ(МИН(КОДСИМВ(ПСТР(A1;СТРОКА(ДВССЫЛ("1:"&ДЛСТР(A1)));1)))>122;"только рус";"нет только рус")

формула массива.
Даже самый простой вопрос можно превратить в огромную проблему. Достаточно не уметь формулировать вопросы...
www.excel-vba.ru
Просто СПАСИБО [+оказать+]
Считаешь СПАСИБО мало? Яндекс.Деньги: 41001332272872; WM: R298726502453

Alexandr Zlobin

#4
спасибо большое всем!буду искать аналоги функций VBA!

функция code
NULL