Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

чтобы выводились данные по текущей дате

Автор almik, 07.04.2011, 17:29

« назад - далее »

almik

прошу совета, какую функцию применить

имеется:
в первом вертикальном столбце - все даты месяца
во втором - количество, соответствующее каждой дате

надо:
чтобы в отдельной ячейке отображалось количество продукции на текущую (сегодняшнюю) дату

как сделать?

Serge 007

Раз вопрос без примера, то и ответ "приблизительный":
=ВПР(текущая_дата;Столбец1Столбец2;2;0)
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Василий Алибабаевич


almik


almik

снова вопрос:

а если эти два вертикальных столбца - не рядом, а разведены?
тогда сплошной массив обозначить не получается, а надо указывать столбцы отдельно.
как?

DV68

=индекс(D:D;поискпоз(СЕГОДНЯ();A:A;0))

Vic Voodoo

Я бы добавил столбец слева от столбца количеств. Прописал бы в нем формулу
=если(RC[-n]=Сегодня();RC[1];0)
где n разность между номером столбца с количествами и номером столбца с датами.
А в ту самую "отдельную ячейку" вставил бы сумму созданного столбца.

almik

1. а если даты, с которыми надо сравнивать текущую дату, отображены в текстовом формате, а не в формате "дата"?
(т.е. по вертикали "01".. "03".. "14".., и весь столбец просто называется "март")
кажется, функция "ДЕНЬ", чтобы формула узнавала цифры как дни?

2. также данные нужны СЕГОДНЯ на ВЧЕРА. точнее, на предыдущий рабочий день (минуя выходные и праздничные дни).

и как всё это совместить в одной формуле??

DV68

Если хотите получить быстрый и правильный ответ, потрудитесь уважать тех к кому обращаетесь за помощью и составьте небольшой пример в формате .xls того что есть и что хочется получить в итоге.

almik


DV68

Ответил на другом форуме.
повторюсь:
G5:
=ИНДЕКС(C5:C33;ДЕНЬ(РАБДЕНЬ($G1;-1)))

P.s. Функция РАБДЕНЬ работает при подключенном Пакете анализа.

almik

Дмитрий, спасибо,
Пакет подключил, цифры отобразились.

Но в G5 и H5 (куда забиваем искомые формулы) просто перенеслись значения из C5 и D5 (данные на 1-е апреля), тогда как надо, чтобы перенеслись С11 и D11 (данные на 7 апреля).
А почему так?

almik

а если функцию по выходным и рабочим дням вообще не использовать?

я вложил изменённый пример
там выходные дни вообще вырезаны, остался только вертикальный сплошной список рабочих дней.

тогда ведь "-1" не подходит к текущей дате.. надо просто к предыдущей нужной дате (следующая сверху ячейка) отнести.

DV68

Можно формулами массива:
=ИНДЕКС(C5:C25;ПОИСКПОЗ(ДЕНЬ(СЕГОДНЯ())-1;--$B5:$B25))
=ВПР(ДЕНЬ(СЕГОДНЯ())-1;--$B5:$D25;2)
но лучше так:
=ПРОСМОТР(ДЕНЬ(СЕГОДНЯ())-1;--$B5:$B25;C5:C25)