Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

Перенос списка по текущей дате

Автор Elavio, 28.04.2011, 14:50

« назад - далее »

Elavio

Добрый день ,уважаемые форумчане !

Подскажите в решении такой задачи :

Есть график поставки по поставщикам,расписанный по датам - на одном листе

На другом нужно ,чтобы на основании текущей даты подтягивался весь список товаров для заказа по поставщикам на текущюю дату .(то есть подтягивался код поставщика,наименовани поставщика,код товара и товар)

Прилагаю пример !

Возможно есть другие идеи по отображению графика и списка на текущую дату .

Буду очень благодарен за любыве подсказки ,а то на работе уже завал ((((

Mart222

Через формулу массива, указываем нужную дату - получаем таблицу с выборкой.

nilem

Или так. В А2 пишем дату, нажимаем кнопку.

Serge 007

Цитата: Mart222 от 28.04.2011, 15:43
Через формулу массива, указываем нужную дату - получаем таблицу с выборкой.
Или попроще:=ИНДЕКС('график-то что есть'!$A$3:$D$27;НАИМЕНЬШИЙ(ЕСЛИ(('график-то что есть'!$E$3:$K$27<>0)*'график-то что есть'!$E$2:$K$2=$A$2;СТРОКА($1:$24));СТРОКА(A1));СТОЛБЕЦ(A1))
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

_Boroda_

Еще вариант. Можно добавлять строки значений и столбцы дат
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Elavio

Спасибо всем ребятам за варианты !!!!

Сейчас осваиваю .

С кнопкой интерестный вариант - для себя возьму .Шефу ,наверное ,что-то попроще предложу )))

Elavio

Вопрос к _Boroda_

Не увидел в формуле ссылок на лист с графиками - если прописать в другом файле - подтянется то,что надо ?

Наперед извиняюсь за возможно некорректный вопрос

=ИНДЕКС(вывод;НАИМЕНЬШИЙ(ЕСЛИ(единички;СТРОКА(вывод)-2;СЧЁТЗ(вывод)+1);СТРОКА()-3))

Elavio

_Boroda_ отзовитесь ,пожалуйста,

ломаю голову....

Serge 007

Цитата: Elavio от 28.04.2011, 18:08
_Boroda_ отзовитесь ,пожалуйста,

ломаю голову....
А если бы обращались к форуму - давно получили бы ответ.
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Elavio

Понял,был не прав...

Если кто-то обьяснит,буду благодарен...

_Boroda_

О. Как я вовремя.
Сергей абсолютно прав. Я же не могу все время у компа сидеть. А другие мастера знают нисколько не меньше.

А по существу - есть такая штука, называется именованный диапазон. Там формулы сидят. Посмотреть можно, нажав Контрл+F3.
единички и вывод - это они и есть.
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Elavio

Спасибо ,_Boroda_

Ребят (уважаемые мастера), я никого обидеть или распалить конкуренцию не хотел - спрашивал у того ,к чему примеру был вопрос ...

В другой раз учту ,если что ...извините

Ваш форум не раз выручал .

Аиша

#12
Цитата: nilem от 28.04.2011, 16:02
Или так. В А2 пишем дату, нажимаем кнопку.
Добрый день!
Замечательный макрос! Только помогите мне пожалуйста переделать его под себя, а то я не очень в этом сильно, переделала, а по дате не выбирает