Новости:

Прикрепить к сообщению можно только файлы xls, gif, jpg, rar, zip,7z, bas, frm, cls, doc размером до 150 Кб.

Главное меню

Подсчет серий

Автор Bomont, 28.04.2011, 19:32

« назад - далее »

Bomont

Господа форумчане, искренне надеюсь на Вашу смекалку.

Есть задачка, а точнее ряд данных, например:
-1
-2
1
-1
1
2
3

Требуется, желательно одной формулой, если это конечно возможно вычислить количество серий цифр с одинаковым знаком, например подсчитать кол-во серий начиная со второй цифры и далее 5 цифр (выборка, сколько взять цифр и начиная откуда будет задаваться вручную).
Т.е. для примера 5 цифр из выборки будут следующими: -2,1,-1,1,2. Здесь серий получится 4, это: -,+,-,+ (т.е. 4 серии цифр с одинаковым знаком следующих друг за другом). Возможно ли подсчитать без использования макроса?
Прикрепляю пример.

Заранее спасибо за помощь!

MCH

=СУММПРОИЗВ(--(ЗНАК(B3:B14)<>ЗНАК(B4:B15)))

Bomont

Более чем оригинально ) Спасибо, помогло!