Как подсчитать кол-во ячеек содержащие определенный месяц?

Автор savage_s, 03.05.2011, 13:44

« назад - далее »

savage_s

Есть: столбец с датами (диапазон: весь год)
Нужно: подсчитать количество дат с заданным месяцем, т.е. сколько ячеек содержат даты с определенным месяцем (например: количество ячеек содержащих даты за январь)
Понимаю, что задача простая, но ни как не могу понять, как написать условие сравнения. Пробовал:
=СУММЕСЛИ(A2:A20;(МЕСЯЦ($A2:$A20)=МЕСЯЦ($G$2)))
[12:17:47] Дмитрий: =СУММ(ЕСЛИ(МЕСЯЦ(A3:A19)=1;1;0))
Но, не считает =(
Подскажите, что не так в размышлениях.

nilem

Попробуйте так:
=СУММПРОИЗВ(--(МЕСЯЦ(A2:A20)=МЕСЯЦ(G2)))

или:
=СУММ(--(МЕСЯЦ(A2:A20)=МЕСЯЦ(G2)))  - формула массива

savage_s

Вот в этом , то и загвоздка. пробовал и так делать, не считает =(
Вроде задача простая, но .... Хотелось бы решить ее без использования дополнительных столбцов и т.д.
Не могу додуматься как написать условие сравнения.
пробовал и :
=СЧЁТЕСЛИ(A3:A19;МЕСЯЦ(A3:A19)=G2) , где в G2 написан месяц

MCH


savage_s

Да, формула работает (при условии, что месяца обозначены цифрами 1,2,3 и т.д.), но пустая ячейка плюсуется к январю =(

savage_s

Уточню, строки могут добавляться, поэтому хотелось бы указать большой диапазон. В идеале вообще просто столбец.

П.С.: Забыл сказать спасибо.

Ingvar

Цитата: savage_s от 03.05.2011, 14:34
Да, формула работает (при условии, что месяца обозначены цифрами 1,2,3 и т.д.), но пустая ячейка плюсуется к январю =(

А что мешает написать: =СУММЕСЛИ(A:A;A:A;B:B)
Если в столбце А находятся месяцы а в B  то что нужно суммировать.
Или
=СУММЕСЛИ(A:A;A2;B:B)
Аналогично.

Тройка примеров во вложении (1_Пример_1)

PS работает на диапазоне столбец

Ой ))) если нужно количество дат с заданным месяцем посчитать :)) то еще проще.
Есть функция СЧЁТЕСЛИ(A:A;A:A)
При это желательно в столбец А вписать формулу :
=Месяц(ссылка на столбец в формате дата)

Пример во вложении (2_Пример_2_)

savage_s

Суть в том, что ни чего кроме количества дат считать не надо. В столбце "А" находятся даты (куча дат с разными месяцами и числами, но за один год), нужно посчитать сколько записей (ячеек, дат, и т.п.) было за январь, за февраль .....
При этом сам список дат может пополняться новыми записями, поэтому определенный диапазон лучше не ставить. В идеале вести подсчет по всему столбцу.

Serge 007

Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

Serge 007

И ещё несколько более "экономных" вариантов в файле.
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

savage_s

Громаднейшее спасибо.

Кстати не смог найти информацию по поводу символов "--" как обозначение массива =( не просветите по этому поводу?

Serge 007

Цитата: savage_s от 03.05.2011, 15:09
Кстати не смог найти информацию по поводу символов "--" как обозначение массива =( не просветите по этому поводу?
См. здесь.
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

savage_s

Заранее извиняюсь за свою тупоголовость, но не могли бы Вы объяснить еще что значит слово "даты" в МЕСЯЦ(даты). (возвращается ошибка #ИМЯ?)
Поскольку столкнулся с ошибкой, как только создал многостраничную книгу. Где  _сводные_ данные на первом листе, а сами даты для подсчетов на других листах.  Пример такой таблицы во вложении.

nilem

"даты" - видимо, именованный диапазон. Так попробуйте, для яч. С6 в сводной:
=СУММПРОИЗВ(--(МЕСЯЦ('таблица 1'!$K$2:$K$100)=C4)*(ЕЧИСЛО('таблица 1'!$K$2:$K$100)))
можно протянуть вправо для всех месяцев.

savage_s

Так возвращается значение (результат вычислений) 00.01.1900