Новости:

Новая редакция правил форума: 2.4. Если вопрос или ответ содержится во вложенном файле, все-равно кратко описывайте в сообщении вопрос или суть решения. Это необходимо, чтобы тему можно было найти через поиск.

Главное меню

подщет количества значений в таблице по нескольким парамертам

Автор Poltava, 05.05.2011, 12:58

« назад - далее »

Poltava

Есть таблица в которой вскречаеться некое число к примеру 23 нужно подсчитать его количество но только в том случае есть в колонке Категория на сторчку выше стоит ПРОИЗВ. Пример во вложении сам смог сделать только добавив промежуточную колонку выделенную красным, а возможно ли выполнить данную задачу без доп колонки ???
Пример во вложении
Не пытайтесь спорить с дебилом. Иначе вы опуститесь до его уровня. Где он задавит вас своим опытом.

_Boroda_

=СУММ((A5:H56="23")*(I4:I55="ПРОИЗВ")) формула массива

или
=СУММПРОИЗВ((A5:H56="23")*(I4:I55="ПРОИЗВ"))
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Poltava

Не пытайтесь спорить с дебилом. Иначе вы опуститесь до его уровня. Где он задавит вас своим опытом.

Poltava

и вопрос вдогонку здесь 2 диапазона один из них на одну клеточку смещен из за разности в одну строку в книге уже есть подобный динамический диапазон можно ли как то его использовать чтобы не добавлять новые имена диапазонов. если перенести на данный пример то существующие диапазоны  Д1 = A4:H57  и  Д2 = I4:I57 можно ли както выжать данные с их использованием ???
Не пытайтесь спорить с дебилом. Иначе вы опуститесь до его уровня. Где он задавит вас своим опытом.

_Boroda_

сделай Д1 = A4:H58  и  Д2 = I3:I57

тогда
=СУММПРОИЗВ((Д1="23")*(Д2="ПРОИЗВ"))
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

Poltava

Да это очевидный вариант но в том то и фишка что Д1 и Д2 фигурируют в других формулах и хочеться из использовать а так нужно делать Д3 и Д4 но я так понял что то что я хочю не получиться прийдеться делать Д1 = A4:H57  и  Д2 = I4:I5  и Д3 = A4:H58  и  Д4 = I3:I57
Не пытайтесь спорить с дебилом. Иначе вы опуститесь до его уровня. Где он задавит вас своим опытом.

Poltava

И снова драсте. Поставленная выше задача как оказалось намного сложнее. Вот так всегда делал делал а оказалось что не учел еще несколько параметров. Ну и собственно задача: теперь критерий не только 23 но и суббота это или воскресенье в зависимости от графика!!!! конкретней попробовал объяснить во вложении.
Не пытайтесь спорить с дебилом. Иначе вы опуститесь до его уровня. Где он задавит вас своим опытом.

MCH

решение "в лоб"
=СУММПРОИЗВ(((ПРАВСИМВ($A$3:$O$3;2)<>"Вс")*($P$4:$P$29="6:00")+(ПРАВСИМВ($A$3:$O$3;2)<>"Сб")*(ПРАВСИМВ($A$3:$O$3;2)<>"Вс")*($P$4:$P$29="8:00"))*($Q$4:$Q$29="ПРОИЗВ")*($A$5:$O$30="23"))

Poltava

Ну спасибо как я сам не додумался почти сутки мучался!!! :'( Спасибо за ответ ну и конечно +1
Не пытайтесь спорить с дебилом. Иначе вы опуститесь до его уровня. Где он задавит вас своим опытом.