Новости:

Теперь на форум можно залогиниться / зарегистрироваться с помощью ВКонтакте. Уже существующие пользователи могут связать свою учетную запись с аккаунтом ВКонтакте одним кликом в профиле пользователя http://forum.msexcel.ru/index.php?action=profile;area=account

Главное меню

Как подсчитать количество ячеек по заданной подстроке.

Автор nebster, 06.05.2011, 07:45

« назад - далее »

nebster

Всем Привет. Есть столбец с текстовыми данными. Подскажите, как подсчитать количество ячеек, содержащих заданную подстроку?

GWolf

#1
Если макросом, то InStr Вам в помощь.
Их help: на скрепке.
Путей к вершине - множество. Этот один из многих!

nebster

А можно сделать это без макросов, стандартными функциями?

GWolf

Путей к вершине - множество. Этот один из многих!

nebster

Спасибо за ссылку, но ответа пока не нашел. Подскажете, а в excel есть готовая функция, которая считает количество ячеек по их содержимому. Например, сколько ячеек в столбце имеют значение 5?

nebster

Цитата: Serge 007 от 06.05.2011, 09:31
]Пример давайте что есть и что должно получится.
Пока нет ничего. Напрашивается такое решение: использовать "суммесли", а внутри, как критерий функцию "поиск". Но она она суммирует значения в ячейках, а не считает количество ячеек. Не могу найти функцию, которая бы считала количество ячеек.

_Boroda_

#6
=СЧЁТЕСЛИ(A27:A34;"*пл*")
ищем вхождение буковок пл в диапазон А27:А34

Для выложенного на пост ниже примера уважаемого GWolfа

=СЧЁТЕСЛИ(B5:B15;"*"&E2&"*")
Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

GWolf

На скрепке сделал, функциями листа. М.б. коряво, пусть знатоки сильно не бьют и подправят!
Путей к вершине - множество. Этот один из многих!

_Boroda_

Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

nebster

#9
Цитата: _Boroda_ от 06.05.2011, 10:05
=СЧЁТЕСЛИ(A27:A34;"*пл*")
ищем вхождение буковок пл в диапазон А27:А34

Спасибо, а то я долго бы искал нужную функцию.

Назрел еще один вопрос: Можно ли в функции счетесли использовать логическое или, чтобы она проверяла два вхождения в строку, и если хотя бы одно было верным, То все равно суммировало мы ячейку?

_Boroda_

когда в строку входят сразу и первый, и второй, то считаем как два вхождения:
=СЧЁТЕСЛИ(A27:A34;"*первый*")+СЧЁТЕСЛИ(A27:A34;"*второй*")

когда в строку входят сразу и первый, и второй, то считаем как одно вхождение:
=СЧЁТЕСЛИ(A27:A34;"*первый*")+СЧЁТЕСЛИ(A27:A34;"*второй*")-СЧЁТЕСЛИ(A27:A34;"*первый*второй*")-СЧЁТЕСЛИ(A27:A34;"*второй*первый*")


Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

kimtan

Условия для СЧЁТЕСЛИ() можно также перечислять в массиве констант, например:
=СУММ(СЧЁТЕСЛИ(A27:A34;{"*первый*";"*второй*"}))
Webmoney: E350157549801 Z116603216205 R268084006579

nebster

#12
Спасибо за ответы, помогло.

Правда появился еще один вопрос, но уже по другой теме :)

Есть функция такого вида:
СУММЕСЛИ('Исходные данные'!C2:C31354;"*Какой-то текст*";'Исходные данные'!AF2:AF31354)

Как сделать так, чтобы в качестве критерия брался текст из какой-то ячейки?

Нашел решение.
Если кому интересно:
СУММЕСЛИ('Исходные данные'!C2:C31354;"*"&A93&"*";'Исходные данные'!AF2:AF31354)

nebster

Столкнулся с еще одной проблемой.

Есть 3 столбца. В первом идентификационный номер, во втором дата устройства на работу, в третьем зарплата.
Нужно это все разбить на 9 сегментов в зависимости от стажа (до 2-х лет, от 2-х до 4-х и более 4-х) и зарплаты (до 20, 20-40, выше 40).

Подскажите, как решить данную задачу.
Первое, что интересует, это как подсчитать количество работников в каждом сегменте.
Первое что приходит в голову, это использовать счётеслимн. Но как заставить проверять два критерия напротив одной ячейки?

kimtan

Можно использовать счётеслимн(), но для этого прийдется добавить столбец с подсчетом стажа.
Без файла-примера это пока весь ответ.
Webmoney: E350157549801 Z116603216205 R268084006579