Новости:

К первому сообщению темы должен быть прикреплен файл примера в формате xls*.
Приложив пример, Вы избавите себя и других от вопросов типа "А какой критерий?", "А куда выводить результат?", "А сколько строк?" и все тех же просьб выложить файл. Рисовать за Вас Ваши же таблички с заданиями, а затем и решение к ним, никто желанием не горит. Да и, как показывает практика, в большинстве случаев без файла решения не найти.

Главное меню

Проблема с сохранением в CSV

Автор oc01, 07.05.2011, 10:19

« назад - далее »

oc01

Для импорта файла в MySQL необходимо, чтоб значение дата и время были в формате ГГГГ-ММ-ДД ч:мм. При пересохранении экселевского файла в CSV формат меняется на ДД.ММ.ГГГГ ч:мм. Как его можно заставить сохраниться в нужном формате? Спасибо!

Andrey Lenets

=ТЕКСТ(A1;"ГГГГ-ММ-ДД ЧЧ:ММ"), где A1 ячейка с датой.  ;)

oc01

спасибо, я это пробовал! Только для импорта в MySQL придется постоянно в сохраненном файле дополнительный столбец удалять вручную, что не очень удобно.