Новости:

Из правил форума: Тема должна отражать суть вопроса, топики типа "help please" будут удаляться!

Главное меню

Функция СЧЕТЕСЛИМН не работает

Автор _NATASHENKA_, 19.05.2011, 12:51

« назад - далее »

_NATASHENKA_

Здравствуйте, Всем работающим в Excel!
Столкнулась с функцией счетеслимн.
Необходимо подсчитать количество дней с определенными критериями.
Формула написана, критерии введены, но не считает.
В чем проблема. Прикрепила файл-пример.
Спасибо за  помощь.

Serge 007

Здравствуйте.

Критерии надо писать без знака "="
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390

_Boroda_

Цитироватьитерии надо писать без знака "="
Не согласен. Можно и так, и так.
Тут дело не в этом. Читаем справку:
Применяет условия к ячейкам в нескольких диапазонах и вычисляет количество соответствий всем условиям. Если по-русски, то ячейка должна одновременно равняться и "Р", и "1/10Р", и ...

Для Вашего случая, если я правильно понял, что нужно посчитать все ячейки с буквой "Р", подойдет формула
=СЧЁТЕСЛИ(A1:AE1;"=*Р")

Скажи мне, кудесник, любимец ба'гов...



Яндекс-деньги: 41001632713405
Webmoney: R289877159277; Z102172301748; E177867141995

_NATASHENKA_

=СЧЁТЕСЛИ(A1:AE1;"=*Р").
Спасибо, оказывается все просто  ;D,  считает.

Если это вообще возможно....с какой функцией (кроме пользовательской самостоятельнопрописаннной в VBA) можно выделить значение числа стоящего перед Р (например из 1/10Р=10, а диапозона соответсвенно сумма, а если Р=8 (суммесли)). Пример из прошлого сообщения.


Пойду сама помозгую..... ;D

Serge 007

Цитата: _NATASHENKA_ от 19.05.2011, 13:55
какой функцией можно выделить значение числа стоящего перед Р,например из 1/10Р=10
=ПСТР(N1;НАЙТИ("/";N1)+1;НАЙТИ("Р";N1)-НАЙТИ("/";N1)-1)
Бесплатная помощь: www.excelworld.ru
Платная помощь: sergeyizotov@excelworld.ru
Ю-money: 41001419691823 | WMR:126292472390